summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranonimal2018-05-26 02:14:14 +0000
committeranonimal2018-05-26 02:14:14 +0000
commit67408013e2dcf401377912b870473ec8a6be2db6 (patch)
treec4f89daf97396a884097c7eecb01bdeaf5c47208
parent84eda54cdcc6a5d41b8c95a3034016987769912f (diff)
downloadaur-67408013e2dcf401377912b870473ec8a6be2db6.tar.gz
Bump to v0.12.1.0
-rw-r--r--.SRCINFO16
-rw-r--r--0001-Ignore-GCC-8-warnings.patch43
-rw-r--r--0001-account-fix-build-with-GCC-8.1.0.patch53
-rw-r--r--0001-cmake-do-not-install-into-the-system.patch46
-rw-r--r--PKGBUILD31
5 files changed, 175 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21f3c760483f..b4acb8d72bc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Mar 28 00:57:35 UTC 2018
+# Sat May 26 02:13:52 UTC 2018
pkgbase = monero
pkgdesc = Monero: the secure, private, untraceable currency - release version (includes daemon, wallet and miner)
- pkgver = 0.12.0.0
+ pkgver = 0.12.1.0
pkgrel = 1
url = https://getmonero.org/
arch = x86_64
@@ -16,8 +16,6 @@ pkgbase = monero
makedepends = gtest
makedepends = qt5-tools
depends = boost-libs
- depends = unbound
- depends = miniupnpc
depends = libunwind
depends = openssl
depends = readline
@@ -26,8 +24,14 @@ pkgbase = monero
provides = libmonero-wallet
conflicts = bitmonero-git
conflicts = libmonero-wallet-git
- source = https://github.com/monero-project/monero/archive/v0.12.0.0.tar.gz
- sha256sums = 5e8303900a39e296c4ebaa41d957ab9ee04e915704e1049f82a9cbd4eedc8ffb
+ source = monero::git+https://github.com/monero-project/monero#tag=v0.12.1.0
+ source = 0001-account-fix-build-with-GCC-8.1.0.patch
+ source = 0001-Ignore-GCC-8-warnings.patch
+ source = 0001-cmake-do-not-install-into-the-system.patch
+ sha256sums = SKIP
+ sha256sums = 3802e9a6eb21309c6d08d7da4a1979c369fc6a0d74789f34beaaf60a89e82af2
+ sha256sums = 1881c02eccb500c4ee28bf4bc1f59259fc1216013139f1e77f4255ffca2715fe
+ sha256sums = 653853f9c0fed231a2cec476703f09198e6a87af12bb0a3bfe98b32e48e7a1c5
pkgname = monero
install = monero.install
diff --git a/0001-Ignore-GCC-8-warnings.patch b/0001-Ignore-GCC-8-warnings.patch
new file mode 100644
index 000000000000..7b4d13e336db
--- /dev/null
+++ b/0001-Ignore-GCC-8-warnings.patch
@@ -0,0 +1,43 @@
+From 4685997fbd6687158879f2db0456ce2eb1ff0567 Mon Sep 17 00:00:00 2001
+From: Romain Geissler <romain.geissler@amadeus.com>
+Date: Mon, 19 Feb 2018 12:52:16 +0100
+Subject: [PATCH] Ignore GCC 8 warnings.
+
+(cherry picked from commit 54dab1eebb0dea32d9ea49dad4fa9c98816c21ed)
+---
+ external/rapidjson/document.h | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/external/rapidjson/document.h b/external/rapidjson/document.h
+index 19f5a6a5f..0cde80780 100644
+--- a/external/rapidjson/document.h
++++ b/external/rapidjson/document.h
+@@ -1936,7 +1936,12 @@ private:
+ if (count) {
+ GenericValue* e = static_cast<GenericValue*>(allocator.Malloc(count * sizeof(GenericValue)));
+ SetElementsPointer(e);
++RAPIDJSON_DIAG_PUSH
++#if defined(__GNUC__) && __GNUC__ >= 8
++RAPIDJSON_DIAG_OFF(class-memaccess) // ignore complains from gcc that no trivial copy constructor exists.
++#endif
+ std::memcpy(e, values, count * sizeof(GenericValue));
++RAPIDJSON_DIAG_POP
+ }
+ else
+ SetElementsPointer(0);
+@@ -1949,7 +1954,12 @@ private:
+ if (count) {
+ Member* m = static_cast<Member*>(allocator.Malloc(count * sizeof(Member)));
+ SetMembersPointer(m);
++RAPIDJSON_DIAG_PUSH
++#if defined(__GNUC__) && __GNUC__ >= 8
++RAPIDJSON_DIAG_OFF(class-memaccess) // ignore complains from gcc that no trivial copy constructor exists.
++#endif
+ std::memcpy(m, members, count * sizeof(Member));
++RAPIDJSON_DIAG_POP
+ }
+ else
+ SetMembersPointer(0);
+--
+2.17.0
+
diff --git a/0001-account-fix-build-with-GCC-8.1.0.patch b/0001-account-fix-build-with-GCC-8.1.0.patch
new file mode 100644
index 000000000000..0f4c02a5f731
--- /dev/null
+++ b/0001-account-fix-build-with-GCC-8.1.0.patch
@@ -0,0 +1,53 @@
+From ae6a40dfd76f5fb024b48a83d900cf5e6d02db93 Mon Sep 17 00:00:00 2001
+From: moneromooo-monero <moneromooo-monero@users.noreply.github.com>
+Date: Thu, 24 May 2018 09:12:16 +0100
+Subject: [PATCH] account: fix build with GCC 8.1.0
+
+---
+ src/cryptonote_basic/account.cpp | 2 +-
+ src/daemon/rpc_command_executor.cpp | 2 +-
+ src/rpc/core_rpc_server_commands_defs.h | 2 ++
+ 3 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/cryptonote_basic/account.cpp b/src/cryptonote_basic/account.cpp
+index bab991d19..aac6ec22b 100644
+--- a/src/cryptonote_basic/account.cpp
++++ b/src/cryptonote_basic/account.cpp
+@@ -157,7 +157,7 @@ DISABLE_VS_WARNINGS(4244 4345)
+ void account_base::create_from_viewkey(const cryptonote::account_public_address& address, const crypto::secret_key& viewkey)
+ {
+ crypto::secret_key fake;
+- memset(&fake, 0, sizeof(fake));
++ memset(&unwrap(fake), 0, sizeof(fake));
+ create_from_keys(address, fake, viewkey);
+ }
+ //-----------------------------------------------------------------
+diff --git a/src/daemon/rpc_command_executor.cpp b/src/daemon/rpc_command_executor.cpp
+index 2efb501ea..c6dd9f538 100644
+--- a/src/daemon/rpc_command_executor.cpp
++++ b/src/daemon/rpc_command_executor.cpp
+@@ -973,7 +973,7 @@ bool t_rpc_command_executor::print_transaction_pool_stats() {
+ }
+ else
+ {
+- memset(&res.pool_stats, 0, sizeof(res.pool_stats));
++ res.pool_stats = {};
+ if (!m_rpc_server->on_get_transaction_pool_stats(req, res, false) || res.status != CORE_RPC_STATUS_OK)
+ {
+ tools::fail_msg_writer() << make_error(fail_message, res.status);
+diff --git a/src/rpc/core_rpc_server_commands_defs.h b/src/rpc/core_rpc_server_commands_defs.h
+index 250c88e90..1227afef5 100644
+--- a/src/rpc/core_rpc_server_commands_defs.h
++++ b/src/rpc/core_rpc_server_commands_defs.h
+@@ -1554,6 +1554,8 @@ namespace cryptonote
+ std::vector<txpool_histo> histo;
+ uint32_t num_double_spends;
+
++ txpool_stats(): bytes_total(0), bytes_min(0), bytes_max(0), bytes_med(0), fee_total(0), oldest(0), txs_total(0), num_failing(0), num_10m(0), num_not_relayed(0), histo_98pc(0), num_double_spends(0) {}
++
+ BEGIN_KV_SERIALIZE_MAP()
+ KV_SERIALIZE(bytes_total)
+ KV_SERIALIZE(bytes_min)
+--
+2.17.0
+
diff --git a/0001-cmake-do-not-install-into-the-system.patch b/0001-cmake-do-not-install-into-the-system.patch
new file mode 100644
index 000000000000..729e57bcbb25
--- /dev/null
+++ b/0001-cmake-do-not-install-into-the-system.patch
@@ -0,0 +1,46 @@
+From c68241016d2244018a1099bfb5c6b264dd5cbdc2 Mon Sep 17 00:00:00 2001
+From: redfish <redfish@galactica.pw>
+Date: Sat, 28 Apr 2018 16:04:07 -0400
+Subject: [PATCH] cmake: do not install into the system
+
+This fork is used a vendored dependency, and we should not install it
+into the system, because it conflicts with miniupnpc installed in the
+system.
+---
+ miniupnpc/CMakeLists.txt | 20 --------------------
+ 1 file changed, 20 deletions(-)
+
+diff --git a/miniupnpc/CMakeLists.txt b/miniupnpc/CMakeLists.txt
+index cb997dc..87df7ae 100644
+--- a/miniupnpc/CMakeLists.txt
++++ b/miniupnpc/CMakeLists.txt
+@@ -177,26 +177,6 @@ if (UPNPC_BUILD_TESTS)
+ # set (UPNPC_INSTALL_TARGETS ${UPNPC_INSTALL_TARGETS} testminixml minixmlvalid testupnpreplyparse testigddescparse testminiwget)
+ endif (UPNPC_BUILD_TESTS)
+
+-
+-install (TARGETS ${UPNPC_INSTALL_TARGETS}
+- RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib${LIB_SUFFIX}
+- ARCHIVE DESTINATION lib${LIB_SUFFIX}
+-)
+-install (FILES
+- miniupnpc.h
+- miniwget.h
+- upnpcommands.h
+- igd_desc_parse.h
+- upnpreplyparse.h
+- upnperrors.h
+- upnpdev.h
+- miniupnpctypes.h
+- portlistingparse.h
+- miniupnpc_declspec.h
+- DESTINATION include/miniupnpc
+-)
+-
+ # commented out by Ben Boeckel, who I presume knows what he's doing;)
+ #set (CONFIGURED YES CACHE INTERNAL "")
+
+--
+2.17.0
+
diff --git a/PKGBUILD b/PKGBUILD
index e8dfd63dfd1f..774c00963745 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,39 @@
pkgbase=('monero')
pkgname=('monero' 'libmonero-wallet')
-pkgver=0.12.0.0
+pkgver=0.12.1.0
pkgrel=1
pkgdesc="Monero: the secure, private, untraceable currency - release version (includes daemon, wallet and miner)"
license=('custom:Cryptonote')
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://getmonero.org/"
-depends=('boost-libs' 'unbound' 'miniupnpc' 'libunwind' 'openssl' 'readline' 'zeromq')
+depends=('boost-libs' 'libunwind' 'openssl' 'readline' 'zeromq')
makedepends=('git' 'cmake' 'boost' 'gtest' 'qt5-tools')
provides=('monero' 'libmonero-wallet')
conflicts=('bitmonero-git' 'libmonero-wallet-git')
-source=("https://github.com/monero-project/monero/archive/v${pkgver}.tar.gz")
+source=("${pkgname}"::'git+https://github.com/monero-project/monero#tag=v0.12.1.0'
+ "0001-account-fix-build-with-GCC-8.1.0.patch"
+ "0001-Ignore-GCC-8-warnings.patch"
+ "0001-cmake-do-not-install-into-the-system.patch")
-sha256sums+=('5e8303900a39e296c4ebaa41d957ab9ee04e915704e1049f82a9cbd4eedc8ffb')
+sha256sums+=('SKIP'
+ '3802e9a6eb21309c6d08d7da4a1979c369fc6a0d74789f34beaaf60a89e82af2'
+ '1881c02eccb500c4ee28bf4bc1f59259fc1216013139f1e77f4255ffca2715fe'
+ '653853f9c0fed231a2cec476703f09198e6a87af12bb0a3bfe98b32e48e7a1c5')
-_monero="${pkgbase}-${pkgver}"
-_build=build
+_monero="${pkgbase}"
+_build="build"
+
+prepare()
+{
+ git -C "${pkgname}" submodule update --init --recursive
+
+ cd "${srcdir}/${_monero}"
+ patch -Np1 -i "${srcdir}/0001-account-fix-build-with-GCC-8.1.0.patch"
+ patch -Np1 -i "${srcdir}/0001-Ignore-GCC-8-warnings.patch"
+ patch -Np1 -i "${srcdir}/0001-cmake-do-not-install-into-the-system.patch" -d "${srcdir}/monero/external/miniupnp"
+}
build() {
cd "${srcdir}/${_monero}"
@@ -35,8 +51,7 @@ build() {
}
check() {
- cd "$srcdir/$_monero"
- cd build
+ cd "${srcdir}/${_monero}/${_build}"
# Temporarily disable some a tests:
# * coretests takes too long (~25000s)