summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranonimal2018-10-13 22:06:31 +0000
committeranonimal2018-10-13 22:06:31 +0000
commitc7dfb2eb3f65d25847b9bef11981062f0c3f5605 (patch)
tree9f4e2b0489916c567183587136128b99c33372d9
parent94fa8e713af13eaa3448162b6fa02742902059c0 (diff)
downloadaur-c7dfb2eb3f65d25847b9bef11981062f0c3f5605.tar.gz
Bump to v0.13.0.2
-rw-r--r--.SRCINFO8
-rw-r--r--0001-cmake-do-not-install-into-the-system.patch46
-rw-r--r--PKGBUILD17
3 files changed, 10 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a40898d7dfb..cb50c7d45fa9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jul 12 01:11:33 UTC 2018
+# Sat Oct 13 22:06:24 UTC 2018
pkgbase = monero
pkgdesc = Monero: the secure, private, untraceable currency - release version (includes daemon, wallet and miner)
- pkgver = 0.12.3.0
+ pkgver = 0.13.0.2
pkgrel = 1
url = https://getmonero.org/
arch = x86_64
@@ -25,10 +25,8 @@ pkgbase = monero
provides = libmonero-wallet
conflicts = bitmonero-git
conflicts = libmonero-wallet-git
- source = monero::git+https://github.com/monero-project/monero#tag=v0.12.3.0
- source = 0001-cmake-do-not-install-into-the-system.patch
+ source = monero::git+https://github.com/monero-project/monero#tag=v0.13.0.2
sha256sums = SKIP
- sha256sums = 653853f9c0fed231a2cec476703f09198e6a87af12bb0a3bfe98b32e48e7a1c5
pkgname = monero
install = monero.install
diff --git a/0001-cmake-do-not-install-into-the-system.patch b/0001-cmake-do-not-install-into-the-system.patch
deleted file mode 100644
index 729e57bcbb25..000000000000
--- a/0001-cmake-do-not-install-into-the-system.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From c68241016d2244018a1099bfb5c6b264dd5cbdc2 Mon Sep 17 00:00:00 2001
-From: redfish <redfish@galactica.pw>
-Date: Sat, 28 Apr 2018 16:04:07 -0400
-Subject: [PATCH] cmake: do not install into the system
-
-This fork is used a vendored dependency, and we should not install it
-into the system, because it conflicts with miniupnpc installed in the
-system.
----
- miniupnpc/CMakeLists.txt | 20 --------------------
- 1 file changed, 20 deletions(-)
-
-diff --git a/miniupnpc/CMakeLists.txt b/miniupnpc/CMakeLists.txt
-index cb997dc..87df7ae 100644
---- a/miniupnpc/CMakeLists.txt
-+++ b/miniupnpc/CMakeLists.txt
-@@ -177,26 +177,6 @@ if (UPNPC_BUILD_TESTS)
- # set (UPNPC_INSTALL_TARGETS ${UPNPC_INSTALL_TARGETS} testminixml minixmlvalid testupnpreplyparse testigddescparse testminiwget)
- endif (UPNPC_BUILD_TESTS)
-
--
--install (TARGETS ${UPNPC_INSTALL_TARGETS}
-- RUNTIME DESTINATION bin
-- LIBRARY DESTINATION lib${LIB_SUFFIX}
-- ARCHIVE DESTINATION lib${LIB_SUFFIX}
--)
--install (FILES
-- miniupnpc.h
-- miniwget.h
-- upnpcommands.h
-- igd_desc_parse.h
-- upnpreplyparse.h
-- upnperrors.h
-- upnpdev.h
-- miniupnpctypes.h
-- portlistingparse.h
-- miniupnpc_declspec.h
-- DESTINATION include/miniupnpc
--)
--
- # commented out by Ben Boeckel, who I presume knows what he's doing;)
- #set (CONFIGURED YES CACHE INTERNAL "")
-
---
-2.17.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 01ba8af3fd7c..d191c2df28ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=('monero')
pkgname=('monero' 'libmonero-wallet')
-pkgver=0.12.3.0
+pkgver=0.13.0.2
pkgrel=1
pkgdesc="Monero: the secure, private, untraceable currency - release version (includes daemon, wallet and miner)"
license=('custom:Cryptonote')
@@ -15,11 +15,9 @@ makedepends=('git' 'cmake' 'boost' 'gtest' 'qt5-tools')
provides=('monero' 'libmonero-wallet')
conflicts=('bitmonero-git' 'libmonero-wallet-git')
-source=("${pkgname}"::"git+https://github.com/monero-project/monero#tag=v${pkgver}"
- "0001-cmake-do-not-install-into-the-system.patch")
+source=("${pkgname}"::"git+https://github.com/monero-project/monero#tag=v${pkgver}")
-sha256sums+=('SKIP'
- '653853f9c0fed231a2cec476703f09198e6a87af12bb0a3bfe98b32e48e7a1c5')
+sha256sums+=('SKIP')
_monero="${pkgbase}"
_build="build"
@@ -27,9 +25,6 @@ _build="build"
prepare()
{
git -C "${pkgname}" submodule update --init --recursive --force
-
- cd "${srcdir}/${_monero}"
- patch -Np1 -i "${srcdir}/0001-cmake-do-not-install-into-the-system.patch" -d "${srcdir}/monero/external/miniupnp"
}
build() {
@@ -51,7 +46,8 @@ check() {
# * coretests takes too long (~25000s)
# * libwallet_api_tests fail (Issue #895)
# * unit_tests were run separately above
- CTEST_ARGS+="-E 'core_tests|libwallet_api_tests|unit_tests'"
+ # * hash-variant2-int-sqrt takes too long
+ CTEST_ARGS+="-E 'core_tests|libwallet_api_tests|unit_tests|hash-variant2-int-sqrt'"
echo ">>> NOTE: some tests excluded: $CTEST_ARGS"
make ARGS="$CTEST_ARGS" test
@@ -63,13 +59,14 @@ package_monero() {
# Uncomment for a debug build
# options=(!strip debug)
-
install -Dm644 "${srcdir}/${_monero}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 "${srcdir}/${_monero}/utils/conf/monerod.conf" "${pkgdir}/etc/monerod.conf"
install -Dm644 "${srcdir}/${_monero}/utils/systemd/monerod.service" "${pkgdir}/usr/lib/systemd/system/monerod.service"
+ install -Dm755 "${srcdir}/${_monero}/build/bin/monero-blockchain-ancestry" "${pkgdir}/usr/bin/monero-blockchain-ancestry"
install -Dm755 "${srcdir}/${_monero}/build/bin/monero-blockchain-blackball" "${pkgdir}/usr/bin/monero-blockchain-blackball"
+ install -Dm755 "${srcdir}/${_monero}/build/bin/monero-blockchain-depth" "${pkgdir}/usr/bin/monero-blockchain-depth"
install -Dm755 "${srcdir}/${_monero}/build/bin/monero-blockchain-export" "${pkgdir}/usr/bin/monero-blockchain-export"
install -Dm755 "${srcdir}/${_monero}/build/bin/monero-blockchain-import" "${pkgdir}/usr/bin/monero-blockchain-import"
install -Dm755 "${srcdir}/${_monero}/build/bin/monero-blockchain-usage" "${pkgdir}/usr/bin/monero-blockchain-usage"