summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranonimal2019-01-21 23:04:18 +0000
committeranonimal2019-01-21 23:04:18 +0000
commite062b13fa1432dc699dd14e64a7a76a33bc6b84e (patch)
treee0e8ad0ca796f4639063413d647855eeb7d2068a
parentcbc9f903d1b5f82dec71d989a1b29d6bedd01ecc (diff)
downloadaur-e062b13fa1432dc699dd14e64a7a76a33bc6b84e.tar.gz
Apply fix to miner, now builds with Boost 1.69
-rw-r--r--.SRCINFO6
-rw-r--r--0001-miner-fix-build-with-boost-1.69.patch25
-rw-r--r--PKGBUILD10
3 files changed, 36 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9eb31de47a2e..e2851cdbf75b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Nov 3 10:49:18 UTC 2018
+# Mon Jan 21 19:50:32 UTC 2019
pkgbase = monero
pkgdesc = Monero: the secure, private, untraceable currency - release version (includes daemon, wallet and miner)
pkgver = 0.13.0.4
- pkgrel = 1
+ pkgrel = 2
url = https://getmonero.org/
arch = x86_64
arch = i686
@@ -26,7 +26,9 @@ pkgbase = monero
conflicts = bitmonero-git
conflicts = libmonero-wallet-git
source = monero::git+https://github.com/monero-project/monero#tag=v0.13.0.4
+ source = 0001-miner-fix-build-with-boost-1.69.patch
sha256sums = SKIP
+ sha256sums = f788a74fce1cd33d979836bea90c211a5ba70737353099b834386670e6539367
pkgname = monero
install = monero.install
diff --git a/0001-miner-fix-build-with-boost-1.69.patch b/0001-miner-fix-build-with-boost-1.69.patch
new file mode 100644
index 000000000000..2af1db0969f6
--- /dev/null
+++ b/0001-miner-fix-build-with-boost-1.69.patch
@@ -0,0 +1,25 @@
+From 3bb4b0d41f76483c4ae4d8d62faa4531049badeb Mon Sep 17 00:00:00 2001
+From: moneromooo-monero <moneromooo-monero@users.noreply.github.com>
+Date: Mon, 22 Oct 2018 22:17:15 +0000
+Subject: [PATCH] miner: fix build with boost 1.69
+
+---
+ src/cryptonote_basic/miner.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/cryptonote_basic/miner.cpp b/src/cryptonote_basic/miner.cpp
+index d0b03593e..d8ca2dd35 100644
+--- a/src/cryptonote_basic/miner.cpp
++++ b/src/cryptonote_basic/miner.cpp
+@@ -637,7 +637,7 @@ namespace cryptonote
+ boost::tribool battery_powered(on_battery_power());
+ if(!indeterminate( battery_powered ))
+ {
+- on_ac_power = !battery_powered;
++ on_ac_power = !(bool)battery_powered;
+ }
+ }
+
+--
+2.20.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 89767ad05d3e..cd5499c49340 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase="monero"
pkgname=('monero' 'libmonero-wallet')
pkgver=0.13.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="Monero: the secure, private, untraceable currency - release version (includes daemon, wallet and miner)"
license=('custom:Cryptonote')
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
@@ -15,9 +15,10 @@ makedepends=('git' 'cmake' 'boost' 'gtest' 'qt5-tools')
provides=('monero' 'libmonero-wallet')
conflicts=('bitmonero-git' 'libmonero-wallet-git')
-source=("${pkgname}"::"git+https://github.com/monero-project/monero#tag=v${pkgver}")
+source=("${pkgname}"::"git+https://github.com/monero-project/monero#tag=v${pkgver}"
+ "0001-miner-fix-build-with-boost-1.69.patch")
-sha256sums+=('SKIP')
+sha256sums+=('SKIP' "f788a74fce1cd33d979836bea90c211a5ba70737353099b834386670e6539367")
_monero="${pkgbase}"
_build="build"
@@ -25,6 +26,9 @@ _build="build"
prepare()
{
git -C "${pkgname}" submodule update --init --recursive --force
+
+ cd "${srcdir}/${_monero}"
+ patch -Np1 -i "${srcdir}/0001-miner-fix-build-with-boost-1.69.patch" -d "${srcdir}/monero"
}
build() {