summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranonimal2019-02-21 21:32:20 +0000
committeranonimal2019-02-21 21:32:20 +0000
commitf68e2c0710d211d146cc376b94d193c4eca57a0d (patch)
tree3239e99cad7190c875caf2c5ba66f34c06018184
parente062b13fa1432dc699dd14e64a7a76a33bc6b84e (diff)
downloadaur-f68e2c0710d211d146cc376b94d193c4eca57a0d.tar.gz
Bump to v0.14.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--0001-miner-fix-build-with-boost-1.69.patch25
-rw-r--r--PKGBUILD13
3 files changed, 8 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2851cdbf75b..90458e905213 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jan 21 19:50:32 UTC 2019
+# Thu Feb 21 21:32:12 UTC 2019
pkgbase = monero
pkgdesc = Monero: the secure, private, untraceable currency - release version (includes daemon, wallet and miner)
- pkgver = 0.13.0.4
- pkgrel = 2
+ pkgver = 0.14.0.0
+ pkgrel = 1
url = https://getmonero.org/
arch = x86_64
arch = i686
@@ -25,10 +25,8 @@ pkgbase = monero
provides = libmonero-wallet
conflicts = bitmonero-git
conflicts = libmonero-wallet-git
- source = monero::git+https://github.com/monero-project/monero#tag=v0.13.0.4
- source = 0001-miner-fix-build-with-boost-1.69.patch
+ source = monero::git+https://github.com/monero-project/monero#tag=v0.14.0.0
sha256sums = SKIP
- sha256sums = f788a74fce1cd33d979836bea90c211a5ba70737353099b834386670e6539367
pkgname = monero
install = monero.install
diff --git a/0001-miner-fix-build-with-boost-1.69.patch b/0001-miner-fix-build-with-boost-1.69.patch
deleted file mode 100644
index 2af1db0969f6..000000000000
--- a/0001-miner-fix-build-with-boost-1.69.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 3bb4b0d41f76483c4ae4d8d62faa4531049badeb Mon Sep 17 00:00:00 2001
-From: moneromooo-monero <moneromooo-monero@users.noreply.github.com>
-Date: Mon, 22 Oct 2018 22:17:15 +0000
-Subject: [PATCH] miner: fix build with boost 1.69
-
----
- src/cryptonote_basic/miner.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/cryptonote_basic/miner.cpp b/src/cryptonote_basic/miner.cpp
-index d0b03593e..d8ca2dd35 100644
---- a/src/cryptonote_basic/miner.cpp
-+++ b/src/cryptonote_basic/miner.cpp
-@@ -637,7 +637,7 @@ namespace cryptonote
- boost::tribool battery_powered(on_battery_power());
- if(!indeterminate( battery_powered ))
- {
-- on_ac_power = !battery_powered;
-+ on_ac_power = !(bool)battery_powered;
- }
- }
-
---
-2.20.1
-
diff --git a/PKGBUILD b/PKGBUILD
index cd5499c49340..c592c8ba744d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgbase="monero"
pkgname=('monero' 'libmonero-wallet')
-pkgver=0.13.0.4
-pkgrel=2
+pkgver=0.14.0.0
+pkgrel=1
pkgdesc="Monero: the secure, private, untraceable currency - release version (includes daemon, wallet and miner)"
license=('custom:Cryptonote')
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
@@ -15,10 +15,9 @@ makedepends=('git' 'cmake' 'boost' 'gtest' 'qt5-tools')
provides=('monero' 'libmonero-wallet')
conflicts=('bitmonero-git' 'libmonero-wallet-git')
-source=("${pkgname}"::"git+https://github.com/monero-project/monero#tag=v${pkgver}"
- "0001-miner-fix-build-with-boost-1.69.patch")
+source=("${pkgname}"::"git+https://github.com/monero-project/monero#tag=v${pkgver}")
-sha256sums+=('SKIP' "f788a74fce1cd33d979836bea90c211a5ba70737353099b834386670e6539367")
+sha256sums+=('SKIP')
_monero="${pkgbase}"
_build="build"
@@ -26,9 +25,6 @@ _build="build"
prepare()
{
git -C "${pkgname}" submodule update --init --recursive --force
-
- cd "${srcdir}/${_monero}"
- patch -Np1 -i "${srcdir}/0001-miner-fix-build-with-boost-1.69.patch" -d "${srcdir}/monero"
}
build() {
@@ -82,7 +78,6 @@ package_monero() {
install -Dm755 "${srcdir}/${_monero}/build/bin/monero-wallet-cli" "${pkgdir}/usr/bin/monero-wallet-cli"
install -Dm755 "${srcdir}/${_monero}/build/bin/monero-wallet-rpc" "${pkgdir}/usr/bin/monero-wallet-rpc"
-
}
package_libmonero-wallet() {