summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwowario2020-10-12 12:37:07 +0300
committerwowario2020-10-12 12:37:07 +0300
commit658ff939cf760b3a2ef25bed029e5dc06773b6cd (patch)
tree7aa5b7be0457bc6bc4d2f2c576c4d92aeb28b4ef
downloadaur-658ff939cf760b3a2ef25bed029e5dc06773b6cd.tar.gz
add Alpha build
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD34
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef91291d73b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = monero-feather-git
+ pkgdesc = a free Monero desktop wallet
+ pkgver = v0.1.0.0.cd1cd5cb75
+ pkgrel = 1
+ url = https://featherwallet.org
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = cmake
+ makedepends = boost
+ depends = boost-libs
+ depends = libunwind
+ depends = openssl
+ depends = readline
+ depends = zeromq
+ depends = pcsclite
+ depends = hidapi
+ depends = protobuf
+ depends = miniupnpc
+ depends = libgcrypt
+ depends = qrencode
+ depends = ccache
+ depends = libsodium
+ depends = libpgm
+ depends = expat
+ depends = base-devel
+ depends = qt5-base
+ provides = monero-feather-git
+ source = monero-feather-git::git+https://git.wownero.com/feather/feather
+ sha256sums = SKIP
+
+pkgname = monero-feather-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ae0d75478a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: wowario <wowario[at]protonmail[dot]com>
+# Contributor: wowario <wowario[at]protonmail[dot]com>
+
+pkgbase=('monero-feather-git')
+pkgname=('monero-feather-git')
+pkgver=v0.1.0.0.cd1cd5cb75
+pkgrel=1
+pkgdesc="a free Monero desktop wallet"
+license=('BSD')
+arch=('x86_64')
+url="https://featherwallet.org"
+depends=('boost-libs' 'libunwind' 'openssl' 'readline' 'zeromq' 'pcsclite' 'hidapi' 'protobuf' 'miniupnpc'
+ 'libgcrypt' 'qrencode' 'ccache' 'libsodium' 'libpgm' 'expat' 'base-devel' 'qt5-base')
+makedepends=('git' 'cmake' 'boost')
+provides=('monero-feather-git')
+
+source=("${pkgname}"::"git+https://git.wownero.com/feather/feather")
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ mkdir build && cd build && cmake .. && make release-static -j2
+}
+
+package_feather-git() {
+ install -Dm644 "${srcdir}/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 "${srcdir}/${pkgname}/build/bin/feather" "${pkgdir}/usr/bin/feather"
+}