summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwowario2020-11-30 22:48:13 +0300
committerwowario2020-11-30 22:48:13 +0300
commit8c592a0c02626ad468c76e1d279169810a3678ab (patch)
treef5b5bcfd5a9727856ae7f58fe7c730a49e70fdcf
parent95e3dce94d213be097a74a690a328b9883bdfd82 (diff)
downloadaur-8c592a0c02626ad468c76e1d279169810a3678ab.tar.gz
update PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 504f9c68a970..43a672157110 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = monero-feather-git
pkgdesc = a free Monero desktop wallet
- pkgver = v0.1.0.0.ca5b1df7df
+ pkgver = 0.1.0.33a85e1bd8
pkgrel = 1
url = https://featherwallet.org
arch = x86_64
@@ -12,7 +12,6 @@ pkgbase = monero-feather-git
depends = libunwind
depends = openssl
depends = readline
- depends = zeromq
depends = pcsclite
depends = hidapi
depends = protobuf
@@ -26,7 +25,6 @@ pkgbase = monero-feather-git
depends = qt5-base
depends = qt5-websockets
depends = tor
- provides = monero-feather-git
source = monero-feather-git::git+https://git.wownero.com/feather/feather
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 598dc60e26af..651d588e8c22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,32 @@
# Maintainer: wowario <wowario[at]protonmail[dot]com>
# Contributor: wowario <wowario[at]protonmail[dot]com>
-pkgbase='monero-feather-git'
pkgname='monero-feather-git'
-pkgver='v0.1.0.0.ca5b1df7df'
-pkgrel='1'
+pkgver=0.1.0.33a85e1bd8
+pkgrel=1
pkgdesc='a free Monero desktop wallet'
license=('BSD')
arch=('x86_64')
url="https://featherwallet.org"
-depends=('boost-libs' 'libunwind' 'openssl' 'readline' 'zeromq' 'pcsclite' 'hidapi' 'protobuf' 'miniupnpc' 'libgcrypt' 'qrencode' 'ccache' 'libsodium' 'libpgm' 'expat' 'qt5-base' 'qt5-websockets' 'tor')
+depends=('boost-libs' 'libunwind' 'openssl' 'readline' 'pcsclite' 'hidapi' 'protobuf' 'miniupnpc' 'libgcrypt' 'qrencode' 'libsodium' 'libpgm' 'expat' 'qt5-base' 'qt5-websockets' 'tor')
makedepends=('git' 'cmake' 'boost')
-provides=('monero-feather-git')
source=("${pkgname}"::"git+https://git.wownero.com/feather/feather")
sha256sums=('SKIP')
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "%s.%s" "$(git describe --tags --abbrev=0)" "$(git rev-parse --short=9 HEAD)"
+}
+
build() {
cd "${srcdir}/${pkgname}"
git submodule update --init --recursive
- mkdir build
+ mkdir -p build
cd build
cmake ..
- make -j2
+ make
}
package_monero-feather-git() {