summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2018-08-12 09:12:31 -0400
committerredfish2018-08-12 09:12:31 -0400
commit23cef275b96fbdc42dfb0da5940edcd513c2b538 (patch)
tree2075a24e4f01cdf81c6854ddc76ea4798fa02285
parente0e134fa8a0aa9d60308b4f22da851e9d7f45fba (diff)
downloadaur-23cef275b96fbdc42dfb0da5940edcd513c2b538.tar.gz
equalize cmake flags between build and check
Otherwise, check forces the (almost) whole repo to be rebuilt even after build() had just built everything. But, this only happened on ARM architectures for some reason.
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cacbc2bccdda..8fa3806740a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -50,6 +50,11 @@ prepare() {
git pull --no-edit origin refs/pull/3/head # fixes conflict with system miniupnp upon installation
}
+CMAKE_FLAGS+=" -DCMAKE_BUILD_TYPE=$_buildtype "
+CMAKE_FLAGS+=" -DCMAKE_INSTALL_PREFIX=/usr "
+CMAKE_FLAGS+=" -DBUILD_GUI_DEPS=ON "
+CMAKE_FLAGS+=" -Wno-dev " # silence warnings for devs
+
build() {
cd "$srcdir/$_gitname"
@@ -60,18 +65,11 @@ build() {
_buildtype+="Release"
fi
- CMAKE_FLAGS+=" -DCMAKE_BUILD_TYPE=$_buildtype "
- CMAKE_FLAGS+=" -DCMAKE_INSTALL_PREFIX=/usr "
- CMAKE_FLAGS+=" -DBUILD_TESTS=OFF "
- CMAKE_FLAGS+=" -DBUILD_GUI_DEPS=ON "
-
# For OpenSSL v1.0
#CMAKE_FLAGS+=" -DOPENSSL_ROOT_DIR='/usr/include/openssl-1.0;/usr/lib/openssl-1.0 "
- CMAKE_FLAGS+=" -Wno-dev " # silence warnings for devs
-
mkdir -p $_builddir && cd $_builddir
- cmake $CMAKE_FLAGS ..
+ cmake $CMAKE_FLAGS -DBUILD_TESTS=OFF ..
make
}
@@ -79,7 +77,7 @@ check() {
cd "$srcdir/$_gitname"
cd $_builddir
- cmake -DBUILD_TESTS=ON ..
+ cmake $CMAKE_FLAGS -DBUILD_TESTS=ON ..
make
# Run unit_tests test separately to exclude DNS tests which often fail with