summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2018-09-29 18:01:37 -0400
committerredfish2018-09-29 18:18:29 -0400
commit4d9bf1077f7a0e14b99d6e2b5150a1cc11560b70 (patch)
treecf30b90cbed8f53f71e47768e4671fa4a88a4595
parent23cef275b96fbdc42dfb0da5940edcd513c2b538 (diff)
downloadaur-4d9bf1077f7a0e14b99d6e2b5150a1cc11560b70.tar.gz
update to 0.13.0.1~RC1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32e7a78c37d4..3ec53de7c929 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Aug 7 23:21:03 UTC 2018
+# Sat Sep 29 22:04:13 UTC 2018
pkgbase = monero-git
pkgdesc = Peer-to-peer anonymous digital currency (daemon, CLI wallet, and wallet API library)
- pkgver = 0.12.3.0
+ pkgver = 0.13.0.1~RC1
pkgrel = 1
url = https://getmonero.org/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 8fa3806740a4..1255094f7b12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=('monero-git')
pkgname=('monero-git' 'libmonero-wallet-git')
_gitname='monero'
-pkgver=0.12.3.0
+pkgver=0.13.0.1~RC1.r6786.ga8589411
pkgrel=1
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://getmonero.org/"
@@ -41,13 +41,8 @@ prepare() {
#git remote add up $_upstream
#git pull --no-edit up refs/pull/xxxx/head
+ git revert --no-edit cd5638f894954a8424af6bd22f4386b121e5dc8f # PR #4417 breaks build
git pull --no-edit origin refs/pull/4159/head # fixes #4228
- git pull --no-edit origin refs/pull/4165/head # fixes ringdb test failing
-
- patch -p1 < ../cmake-libsodium.patch
-
- cd external/miniupnp
- git pull --no-edit origin refs/pull/3/head # fixes conflict with system miniupnp upon installation
}
CMAKE_FLAGS+=" -DCMAKE_BUILD_TYPE=$_buildtype "
@@ -81,19 +76,19 @@ check() {
make
# Run unit_tests test separately to exclude DNS tests which often fail with
- # DNS nameservers configured on some systems (#2172)
+ # DNS nameservers configured on some systems (#2172). TODO: check if #4464 fixes.
EXCLUDED_UNIT_TESTS+='DNSResolver.IPv4Failure'
EXCLUDED_UNIT_TESTS+=':DNSResolver.DNSSECSuccess'
EXCLUDED_UNIT_TESTS+=':AddressFromURL.Failure'
- EXCLUDED_UNIT_TESTS+=':ringdb.not_found' # PR #4165
+ EXCLUDED_UNIT_TESTS+=':is_hdd.linux_os_root' # fails on SSD (PR#4474)
tests/unit_tests/unit_tests --gtest_filter="-$EXCLUDED_UNIT_TESTS" \
--data-dir ../tests/data
# Temporarily disable some a tests:
- # * coretests takes too long (~25000s)
+ # * coretests, hash-variant2-int-sqrt take too long (~25000s, 250s)
# * libwallet_api_tests fail (Issue #895)
# * unit_tests were run separately above
- CTEST_ARGS+="-E 'core_tests|libwallet_api_tests|unit_tests'"
+ CTEST_ARGS+="-E 'core_tests|hash-variant2-int-sqrt|libwallet_api_tests|unit_tests'"
echo ">>> NOTE: some tests excluded: $CTEST_ARGS"
make ARGS="$CTEST_ARGS" test