summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2017-09-09 13:21:22 -0400
committerredfish2017-09-09 13:21:22 -0400
commitba740afd3e07a2a9ed5cad0bfd1db8c9016db005 (patch)
treeb39142f75919ec3037ec2a5a6b71ce06783d90b5
parenta3055d530502dd6d827b0b95fb45123031c2eba7 (diff)
downloadaur-ba740afd3e07a2a9ed5cad0bfd1db8c9016db005.tar.gz
use service and config files from upstream
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--monerod.conf7
-rw-r--r--monerod.service22
4 files changed, 6 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fac2d3538ed..02c4bf7c536b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Sep 7 22:10:34 UTC 2017
+# Sat Sep 9 17:15:38 UTC 2017
pkgbase = bitmonero-git
pkgdesc = Peer-to-peer anonymous digital currency (daemon, CLI wallet, and wallet API library)
pkgver = 0.11.0.0
@@ -20,11 +20,7 @@ pkgbase = bitmonero-git
depends = readline
depends = openssl
source = monero::git+https://github.com/monero-project/monero.git
- source = monerod.service
- source = monerod.conf
md5sums = SKIP
- md5sums = 978b5dda921ad298d93eaf701094f835
- md5sums = 7115d61857ce249a3e9ccf2c6bc4f00b
pkgname = monero-git
install = monero.install
diff --git a/PKGBUILD b/PKGBUILD
index 2d0912abc0e0..262ab40d2f99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,14 +16,9 @@ makedepends=('git' 'cmake' 'boost' 'gtest')
pkgdesc="Peer-to-peer anonymous digital currency (daemon, CLI wallet, and wallet API library)"
-source=("$_gitname::git+https://github.com/monero-project/monero.git"
- "monerod.service"
- "monerod.conf"
-)
-
-md5sums=('SKIP'
- '978b5dda921ad298d93eaf701094f835'
- '7115d61857ce249a3e9ccf2c6bc4f00b')
+source=("$_gitname::git+https://github.com/monero-project/monero.git")
+
+md5sums=('SKIP')
_builddir=build
@@ -99,8 +94,8 @@ package_monero-git() {
install -D -m755 "$srcdir/$_gitname/build/bin/monero-blockchain-import" "$pkgdir/usr/bin/monero-blockchain-import"
install -D -m755 "$srcdir/$_gitname/build/bin/monero-blockchain-export" "$pkgdir/usr/bin/monero-blockchain-export"
- install -Dm644 $srcdir/monerod.service "${pkgdir}/usr/lib/systemd/system/monerod.service"
- install -Dm644 "$srcdir/monerod.conf" "$pkgdir/etc/monerod.conf"
+ install -Dm644 $srcdir/$_gitname/utils/systemd/monerod.service "${pkgdir}/usr/lib/systemd/system/monerod.service"
+ install -Dm644 "$srcdir/$_gitname/utils/conf/monerod.conf" "$pkgdir/etc/monerod.conf"
install -D -m644 "$srcdir/$_gitname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/monerod.conf b/monerod.conf
deleted file mode 100644
index 9b391dfa1c10..000000000000
--- a/monerod.conf
+++ /dev/null
@@ -1,7 +0,0 @@
-# Configuration for monerod
-# Syntax: any command line option may be specified as 'clioptionname=value'.
-# See 'monerod --help' for all available options.
-
-data-dir=/var/lib/monero
-log-file=/var/log/monero/monero.log
-log-level=0
diff --git a/monerod.service b/monerod.service
deleted file mode 100644
index 9948b729bc6c..000000000000
--- a/monerod.service
+++ /dev/null
@@ -1,22 +0,0 @@
-[Unit]
-Description=Monero cryptocurrency node
-After=network.target
-
-[Service]
-User=monero
-Group=monero
-WorkingDirectory=~
-
-Type=forking
-ExecStart=/usr/bin/monerod --config-file /etc/monerod.conf --detach
-
-# This is necessary because monerod does not yet support
-# writing a PID file, which means systemd tries to guess the PID
-# by default, but it guesses wrong (sometimes, depending on
-# random timing of events), because the daemon forks twice.
-# The ultimate fix is for the daemon to write a PID file, and
-# a workaround is to disable the guessing feature in systemd.
-GuessMainPID=no
-
-[Install]
-WantedBy=multi-user.target