summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2019-06-19 23:32:36 -0400
committerredfish2019-06-19 23:32:36 -0400
commite524ad53ffc5bf4bb47ec8254d19f117271fabf3 (patch)
tree9da8d6a8abaf4a475c85be82646a759f8f467f7c
parent581ef5c8914fca84a2ddbd482e077a5566240134 (diff)
downloadaur-e524ad53ffc5bf4bb47ec8254d19f117271fabf3.tar.gz
0.14.1.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a4138e322a6..2f375b68f17f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Mar 2 06:23:49 UTC 2019
pkgbase = monero-git
pkgdesc = Peer-to-peer anonymous digital currency (daemon, CLI wallet, and wallet API library)
- pkgver = 0.14.0.0
+ pkgver = 0.14.1.0
pkgrel = 1
url = https://getmonero.org/
arch = x86_64
@@ -10,6 +8,7 @@ pkgbase = monero-git
arch = armv7h
arch = aarch64
license = custom:Cryptonote
+ checkdepends = python-requests
makedepends = git
makedepends = cmake
makedepends = boost
@@ -21,6 +20,8 @@ pkgbase = monero-git
depends = readline
depends = zeromq
depends = pcsclite
+ depends = hidapi
+ depends = protobuf
source = monero::git+https://github.com/monero-project/monero.git
sha256sums = SKIP
@@ -31,7 +32,7 @@ pkgname = monero-git
backup = etc/monerod.conf
pkgname = libmonero-wallet-git
- provides = libmonero-wallet=0.14.0.0
+ provides = libmonero-wallet=0.14.1.0
conflicts = libmonero-wallet
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index f7de2bf8bd24..f5a1cca91adf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,16 @@
pkgbase=('monero-git')
pkgname=('monero-git' 'libmonero-wallet-git')
_gitname='monero'
-pkgver=0.14.0.0
+pkgver=0.14.1.0
pkgrel=1
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://getmonero.org/"
license=('custom:Cryptonote')
-depends=('boost-libs>=1.45' 'openssl' 'libunwind' 'readline' 'zeromq' 'pcsclite')
+depends=('boost-libs>=1.45' 'openssl' 'libunwind' 'readline' 'zeromq' 'pcsclite'
+ 'hidapi' 'protobuf')
makedepends=('git' 'cmake' 'boost' 'gtest' 'qt5-tools')
+checkdepends=('python-requests')
pkgdesc="Peer-to-peer anonymous digital currency (daemon, CLI wallet, and wallet API library)"
_upstream=https://github.com/monero-project/monero.git
@@ -39,8 +41,6 @@ prepare() {
# To apply PRs
#git remote add up $_upstream
#git pull --no-edit up refs/pull/xxxx/head
-
- git pull --no-edit origin refs/pull/4159/head # fixes #4228
}
CMAKE_FLAGS+=" -DCMAKE_BUILD_TYPE=$_buildtype "
@@ -87,7 +87,9 @@ check() {
# * coretests, hash-variant2-int-sqrt take too long (~25000s, 250s)
# * libwallet_api_tests fail (Issue #895)
# * unit_tests were run separately above
- CTEST_ARGS+="-E 'core_tests|hash-variant2-int-sqrt|libwallet_api_tests|unit_tests'"
+ # * functional_tests_rpc: take too lon (~1000s on ARM)
+ # * cnv4-jit: take too lon (~1000s on ARM)
+ CTEST_ARGS+="-E 'core_tests|hash-variant2-int-sqrt|libwallet_api_tests|unit_tests|functional_tests_rpc|cnv4-jit'"
echo ">>> NOTE: some tests excluded: $CTEST_ARGS"
make ARGS="$CTEST_ARGS" test