summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandaruKasa2022-10-08 02:11:49 +0300
committerSandaruKasa2022-10-08 02:11:49 +0300
commit943b76a19b56916d6d1e7a0738845f1916cee4c2 (patch)
tree4d9572924cf55858b548bb84b7ae45e183ee6902
downloadaur-943b76a19b56916d6d1e7a0738845f1916cee4c2.tar.gz
Drop-down menus seem to be working with the static binary
-rw-r--r--.SRCINFO32
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD24
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ae6c7f02649
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = monero-gui-static-bin
+ pkgdesc = Monero: the secure, private, untraceable peer-to-peer currency
+ pkgver = 0.18.1.2
+ pkgrel = 1
+ url = https://www.getmonero.org
+ arch = x86_64
+ license = custom
+ depends = gcc-libs
+ depends = glib2
+ depends = glibc
+ depends = libglvnd
+ depends = libx11
+ depends = libxau
+ depends = libxcb
+ depends = libxdmcp
+ depends = libxkbcommon
+ depends = libxkbcommon-x11
+ depends = pcre
+ depends = systemd-libs
+ depends = xcb-util
+ depends = xcb-util-image
+ depends = xcb-util-keysyms
+ depends = xcb-util-renderutil
+ depends = xcb-util-wm
+ provides = monero
+ provides = monero-gui
+ conflicts = monero
+ conflicts = monero-gui
+ source = https://downloads.getmonero.org/gui/monero-gui-linux-x64-v0.18.1.2.tar.bz2
+ sha256sums = 1f9406044434eea770f1548a5bad5708f326f7295fb7c12d6c607ff783018a08
+
+pkgname = monero-gui-static-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2d60fda9ca35
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.*
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8340d45b13d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: SandaruKasa <sandarukasa plus aur at ya dot ru>
+
+pkgname=monero-gui-static-bin
+pkgver=0.18.1.2
+pkgrel=1
+pkgdesc="Monero: the secure, private, untraceable peer-to-peer currency"
+arch=(x86_64)
+url="https://www.getmonero.org"
+license=('custom')
+depends=(
+ gcc-libs glib2 glibc libglvnd libx11 libxau libxcb libxdmcp libxkbcommon
+ libxkbcommon-x11 pcre systemd-libs xcb-util xcb-util-image xcb-util-keysyms
+ xcb-util-renderutil xcb-util-wm
+)
+provides=(monero monero-gui)
+conflicts=(monero monero-gui)
+source=("https://downloads.getmonero.org/gui/monero-gui-linux-x64-v${pkgver}.tar.bz2")
+sha256sums=('1f9406044434eea770f1548a5bad5708f326f7295fb7c12d6c607ff783018a08')
+
+package() {
+ cd "monero-gui-v$pkgver"
+ install -Dm755 monerod monero-wallet-gui extras/* -t "${pkgdir}/usr/bin/"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+}