summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2019-03-02 01:32:38 -0500
committerredfish2019-03-02 01:32:38 -0500
commit1b9910a4c5a5829d831818367682fcb73e1b1dfa (patch)
tree562e972e353b18f640775cac473001ad8c6ce5c4
parentbf3afcfeb1641a4e7a022384684a64b847c47c5e (diff)
downloadaur-1b9910a4c5a5829d831818367682fcb73e1b1dfa.tar.gz
update to 0.14.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--0001-pro-add-libusb-1.0-to-non-static-link-for-Linux.patch40
-rw-r--r--0002-pro-add-protobuf-lib-to-link-commnad-for-Linux.patch31
-rw-r--r--PKGBUILD16
4 files changed, 89 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6615733e463..2a4f6e0d1662 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Nov 18 15:56:07 UTC 2018
+# Sat Mar 2 06:16:51 UTC 2019
pkgbase = monero-wallet-qt
pkgdesc = Official QT GUI wallet for Monero, a private, secure, untraceable peer-to-peer currency
- pkgver = 0.13.0.4
+ pkgver = 0.14.0.0
pkgrel = 1
url = https://getmonero.org/
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = monero-wallet-qt
makedepends = git
makedepends = cmake
makedepends = boost
- depends = libmonero-wallet>=0.13.0.4
+ depends = libmonero-wallet>=0.14.0.0
depends = openssl
depends = boost-libs>=1.45
depends = libunwind
@@ -30,8 +30,8 @@ pkgbase = monero-wallet-qt
depends = qt5-x11extras
depends = qt5-xmlpatterns
provides = monero-wallet-qt
- source = https://github.com/monero-project/monero-gui/archive/v0.13.0.4.tar.gz
- sha256sums = 4c7c5bee1604ea052a83756fd2e67ad97ec059f58040d33356115426aa5adae9
+ source = https://github.com/monero-project/monero-gui/archive/v0.14.0.0.tar.gz
+ sha256sums = 6dab90fbb908dc8fc9889d110ea87d5d1b0f1e802b57f316e0dd59ff0dfcd8b1
pkgname = monero-wallet-qt
diff --git a/0001-pro-add-libusb-1.0-to-non-static-link-for-Linux.patch b/0001-pro-add-libusb-1.0-to-non-static-link-for-Linux.patch
new file mode 100644
index 000000000000..184742b6722d
--- /dev/null
+++ b/0001-pro-add-libusb-1.0-to-non-static-link-for-Linux.patch
@@ -0,0 +1,40 @@
+From 811f81de15a22481d93a2688a466767debc4b64e Mon Sep 17 00:00:00 2001
+From: redfish <redfish@galactica.pw>
+Date: Sat, 19 Jan 2019 16:12:14 -0500
+Subject: [PATCH 1/2] pro: add libusb-1.0 to non-static link for Linux
+
+Fixes failing link on Arch Linux with libmonero-wallet
+4e723843183b12308bce2ef560385ea885ad0174
+
+/usr/bin/ld:
+/usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libwallet_merged.a(transport.cpp.o):
+undefined reference to symbol 'libusb_interrupt_transfer'
+/usr/bin/ld: /usr/lib/libusb-1.0.so.0: error adding symbols: DSO missing from command line
+collect2: error: ld returned 1 exit status
+---
+ monero-wallet-gui.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/monero-wallet-gui.pro b/monero-wallet-gui.pro
+index 2662c5c9..c91cec5e 100644
+--- a/monero-wallet-gui.pro
++++ b/monero-wallet-gui.pro
+@@ -283,7 +283,6 @@ linux {
+ QMAKE_LFLAGS += -static-libgcc -static-libstdc++
+ # contains(QT_ARCH, x86_64) {
+ LIBS+= -lunbound \
+- -lusb-1.0 \
+ -lhidapi-hidraw \
+ -ludev
+ # }
+@@ -305,6 +304,7 @@ linux {
+ -llmdb \
+ -lsodium \
+ -lhidapi-libusb \
++ -lusb-1.0 \
+ -lcrypto $$TREZOR_LINKER
+
+ if(!android) {
+--
+2.20.1
+
diff --git a/0002-pro-add-protobuf-lib-to-link-commnad-for-Linux.patch b/0002-pro-add-protobuf-lib-to-link-commnad-for-Linux.patch
new file mode 100644
index 000000000000..5f0a4128bb6d
--- /dev/null
+++ b/0002-pro-add-protobuf-lib-to-link-commnad-for-Linux.patch
@@ -0,0 +1,31 @@
+From a76cdaa5f75736269bf5f28cb39b76b1cb6d3ad2 Mon Sep 17 00:00:00 2001
+From: redfish <redfish@galactica.pw>
+Date: Sat, 19 Jan 2019 16:34:22 -0500
+Subject: [PATCH 2/2] pro: add protobuf lib to link commnad for Linux
+
+Fixes link failure on Arch Linux with libmonerowallet
+4e723843183b12308bce2ef560385ea885ad0174
+
+/usr/bin/ld:
+/usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libwallet_merged.a(messages-management.pb.cc.o):(.data.rel.ro._ZTVN2hw6trezor8messages10management13SetU2FCounterE[_ZTVN2hw6trezor8messages10management13SetU2FCounterE]+0xb8):
+undefined reference to `google::protobuf::Message::SpaceUsedLong()
+const'
+---
+ monero-wallet-gui.pro | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/monero-wallet-gui.pro b/monero-wallet-gui.pro
+index c91cec5e..c8afa9b7 100644
+--- a/monero-wallet-gui.pro
++++ b/monero-wallet-gui.pro
+@@ -305,6 +305,7 @@ linux {
+ -lsodium \
+ -lhidapi-libusb \
+ -lusb-1.0 \
++ -lprotobuf \
+ -lcrypto $$TREZOR_LINKER
+
+ if(!android) {
+--
+2.20.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 755a74be2b77..2c96c488a47c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: redfish <redfish at galactica dot pw>
pkgname='monero-wallet-qt'
-_monerover=0.13.0.4
+_monerover=0.14.0.0
pkgver=${_monerover}
pkgrel=1
arch=('x86_64' 'i686')
@@ -20,7 +20,9 @@ makedepends=('git' 'cmake' 'boost')
pkgdesc="Official QT GUI wallet for Monero, a private, secure, untraceable peer-to-peer currency"
-source=("https://github.com/monero-project/monero-gui/archive/v${pkgver}.tar.gz")
+source=("https://github.com/monero-project/monero-gui/archive/v${pkgver}.tar.gz"
+ "0001-pro-add-libusb-1.0-to-non-static-link-for-Linux.patch"
+ "0002-pro-add-protobuf-lib-to-link-commnad-for-Linux.patch")
_srcdir=monero-gui-$_monerover
@@ -29,6 +31,12 @@ prepare() {
echo "var GUI_VERSION = \"$pkgver\"" > version.js
echo "var GUI_MONERO_VERSION = \"$_monerover\"" >> version.js
+
+ # The upstream build system adds these dependencies as part of a list
+ # autogenerated during the build of monero. We don't want to have
+ # to build monero just to build the wallet.
+ patch -p1 < ../0001-pro-add-libusb-1.0-to-non-static-link-for-Linux.patch
+ patch -p1 < ../0002-pro-add-protobuf-lib-to-link-commnad-for-Linux.patch
}
build() {
@@ -45,4 +53,6 @@ package() {
install -D -m644 "$srcdir/$_srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-sha256sums=('4c7c5bee1604ea052a83756fd2e67ad97ec059f58040d33356115426aa5adae9')
+sha256sums=('6dab90fbb908dc8fc9889d110ea87d5d1b0f1e802b57f316e0dd59ff0dfcd8b1'
+ '68de913110996c232a284004057f2655c1798472670e31524f86b005f6bf07a8'
+ '76fbeb62810f9f0281320e5b5309395d3239f1dcb8f08b71b98e8a4c06e33e98')