summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2017-09-07 17:56:08 -0400
committerredfish2017-09-07 17:56:08 -0400
commitdbc5c386d1555c45e304e4235c7c501ef7d04473 (patch)
tree30cd860f733f8aeab9f248247d9ce218c4f49036
parent337ea0be2cc3b731b5891c40b1ce2c9f641a6ccd (diff)
downloadaur-dbc5c386d1555c45e304e4235c7c501ef7d04473.tar.gz
link with libreadline patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--link-libreadline.patch16
3 files changed, 25 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40572b6893c0..7300fbdaf5fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Sep 7 21:22:36 UTC 2017
+# Thu Sep 7 21:52:18 UTC 2017
pkgbase = monero-wallet-qt
pkgdesc = Official QT GUI wallet for Monero, a private, secure, untraceable peer-to-peer currency
pkgver = 0.11.0.0
@@ -28,7 +28,9 @@ pkgbase = monero-wallet-qt
depends = qt5-xmlpatterns
provides = monero-wallet-qt
source = https://github.com/monero-project/monero-core/archive/v0.11.0.0.tar.gz
+ source = link-libreadline.patch
md5sums = f75ca71a3cb1ede3d063c489a0fbe1d5
+ md5sums = 398e643b9c4addd1607d582d2712cbf0
pkgname = monero-wallet-qt
diff --git a/PKGBUILD b/PKGBUILD
index 31cfeddcbb36..83864c039db7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,9 +20,11 @@ makedepends=('git' 'cmake' 'boost')
pkgdesc="Official QT GUI wallet for Monero, a private, secure, untraceable peer-to-peer currency"
-source=("https://github.com/monero-project/monero-core/archive/v${pkgver}.tar.gz")
+source=("https://github.com/monero-project/monero-core/archive/v${pkgver}.tar.gz"
+ "link-libreadline.patch")
-md5sums=('f75ca71a3cb1ede3d063c489a0fbe1d5')
+md5sums=('f75ca71a3cb1ede3d063c489a0fbe1d5'
+ '398e643b9c4addd1607d582d2712cbf0')
_srcdir=monero-core-$_monerover
@@ -31,6 +33,8 @@ prepare() {
echo "var GUI_VERSION = \"$pkgver\"" > version.js
echo "var GUI_MONERO_VERSION = \"$_monerover\"" >> version.js
+
+ patch -p1 < ../link-libreadline.patch
}
build() {
diff --git a/link-libreadline.patch b/link-libreadline.patch
new file mode 100644
index 000000000000..dc52128d1464
--- /dev/null
+++ b/link-libreadline.patch
@@ -0,0 +1,16 @@
+--- a/monero-wallet-gui.pro 2017-08-20 04:11:32.099712593 -0400
++++ b/monero-wallet-gui.pro 2017-08-20 04:11:09.899640733 -0400
+@@ -89,11 +89,12 @@
+ !ios {
+ LIBS += -L$$WALLET_ROOT/lib \
+ -lwallet_merged \
+ -lepee \
+ -lunbound \
+- -leasylogging
++ -leasylogging \
++ -lreadline \
+ }
+
+
+ ios {
+ message("Host is IOS")