summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2019-01-19 17:08:43 -0500
committerredfish2019-01-19 17:08:43 -0500
commit3b20a5c686ddbe8b7a5f4f0d6c3cbd08125ca5aa (patch)
treef87ad3fc1578af2331ca19775f157303527d1dd1
parenta3ccc19a616a9b9dde4c8a6a4e346a2878e7c47f (diff)
downloadaur-3b20a5c686ddbe8b7a5f4f0d6c3cbd08125ca5aa.tar.gz
patch with link dependencies
Upstream build system relies on files generated by the build of monero.
-rw-r--r--.SRCINFO6
-rw-r--r--0001-pro-add-libusb-1.0-to-non-static-link-for-Linux.patch40
-rw-r--r--0002-pro-add-protobuf-lib-to-link-commnad-for-Linux.patch31
-rw-r--r--PKGBUILD15
4 files changed, 88 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b250ab1ff54..161b40021b33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Nov 18 16:22:13 UTC 2018
+# Sat Jan 19 22:08:13 UTC 2019
pkgbase = monero-wallet-qt-git
pkgdesc = Official QT GUI wallet for Monero, a private, secure, untraceable peer-to-peer currency
pkgver = 0.13.0.4
@@ -32,7 +32,11 @@ pkgbase = monero-wallet-qt-git
provides = monero-wallet-qt
conflicts = monero-wallet-qt
source = git+https://github.com/monero-project/monero-gui
+ source = 0001-pro-add-libusb-1.0-to-non-static-link-for-Linux.patch
+ source = 0002-pro-add-protobuf-lib-to-link-commnad-for-Linux.patch
sha256sums = SKIP
+ sha256sums = 68de913110996c232a284004057f2655c1798472670e31524f86b005f6bf07a8
+ sha256sums = 76fbeb62810f9f0281320e5b5309395d3239f1dcb8f08b71b98e8a4c06e33e98
pkgname = monero-wallet-qt-git
diff --git a/0001-pro-add-libusb-1.0-to-non-static-link-for-Linux.patch b/0001-pro-add-libusb-1.0-to-non-static-link-for-Linux.patch
new file mode 100644
index 000000000000..184742b6722d
--- /dev/null
+++ b/0001-pro-add-libusb-1.0-to-non-static-link-for-Linux.patch
@@ -0,0 +1,40 @@
+From 811f81de15a22481d93a2688a466767debc4b64e Mon Sep 17 00:00:00 2001
+From: redfish <redfish@galactica.pw>
+Date: Sat, 19 Jan 2019 16:12:14 -0500
+Subject: [PATCH 1/2] pro: add libusb-1.0 to non-static link for Linux
+
+Fixes failing link on Arch Linux with libmonero-wallet
+4e723843183b12308bce2ef560385ea885ad0174
+
+/usr/bin/ld:
+/usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libwallet_merged.a(transport.cpp.o):
+undefined reference to symbol 'libusb_interrupt_transfer'
+/usr/bin/ld: /usr/lib/libusb-1.0.so.0: error adding symbols: DSO missing from command line
+collect2: error: ld returned 1 exit status
+---
+ monero-wallet-gui.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/monero-wallet-gui.pro b/monero-wallet-gui.pro
+index 2662c5c9..c91cec5e 100644
+--- a/monero-wallet-gui.pro
++++ b/monero-wallet-gui.pro
+@@ -283,7 +283,6 @@ linux {
+ QMAKE_LFLAGS += -static-libgcc -static-libstdc++
+ # contains(QT_ARCH, x86_64) {
+ LIBS+= -lunbound \
+- -lusb-1.0 \
+ -lhidapi-hidraw \
+ -ludev
+ # }
+@@ -305,6 +304,7 @@ linux {
+ -llmdb \
+ -lsodium \
+ -lhidapi-libusb \
++ -lusb-1.0 \
+ -lcrypto $$TREZOR_LINKER
+
+ if(!android) {
+--
+2.20.1
+
diff --git a/0002-pro-add-protobuf-lib-to-link-commnad-for-Linux.patch b/0002-pro-add-protobuf-lib-to-link-commnad-for-Linux.patch
new file mode 100644
index 000000000000..5f0a4128bb6d
--- /dev/null
+++ b/0002-pro-add-protobuf-lib-to-link-commnad-for-Linux.patch
@@ -0,0 +1,31 @@
+From a76cdaa5f75736269bf5f28cb39b76b1cb6d3ad2 Mon Sep 17 00:00:00 2001
+From: redfish <redfish@galactica.pw>
+Date: Sat, 19 Jan 2019 16:34:22 -0500
+Subject: [PATCH 2/2] pro: add protobuf lib to link commnad for Linux
+
+Fixes link failure on Arch Linux with libmonerowallet
+4e723843183b12308bce2ef560385ea885ad0174
+
+/usr/bin/ld:
+/usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libwallet_merged.a(messages-management.pb.cc.o):(.data.rel.ro._ZTVN2hw6trezor8messages10management13SetU2FCounterE[_ZTVN2hw6trezor8messages10management13SetU2FCounterE]+0xb8):
+undefined reference to `google::protobuf::Message::SpaceUsedLong()
+const'
+---
+ monero-wallet-gui.pro | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/monero-wallet-gui.pro b/monero-wallet-gui.pro
+index c91cec5e..c8afa9b7 100644
+--- a/monero-wallet-gui.pro
++++ b/monero-wallet-gui.pro
+@@ -305,6 +305,7 @@ linux {
+ -lsodium \
+ -lhidapi-libusb \
+ -lusb-1.0 \
++ -lprotobuf \
+ -lcrypto $$TREZOR_LINKER
+
+ if(!android) {
+--
+2.20.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 458db9397a2b..4e2f3502ed55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,4 @@
# Maintainer: redfish <redfish at galactica dot pw>
-
pkgname='monero-wallet-qt-git'
_monerover=0.13.0.4
pkgver=0.13.0.4
@@ -22,7 +21,9 @@ makedepends=('git' 'cmake' 'boost')
pkgdesc="Official QT GUI wallet for Monero, a private, secure, untraceable peer-to-peer currency"
_repourl=https://github.com/monero-project/monero-gui
-source=("git+$_repourl")
+source=("git+$_repourl"
+ "0001-pro-add-libusb-1.0-to-non-static-link-for-Linux.patch"
+ "0002-pro-add-protobuf-lib-to-link-commnad-for-Linux.patch")
sha256sums=('SKIP')
@@ -44,7 +45,11 @@ prepare() {
echo "var GUI_VERSION = \"$pkgver\"" > version.js
echo "var GUI_MONERO_VERSION = \"$_monerover\"" >> version.js
- git pull --no-edit origin refs/pull/1743/head # link protobuf
+ # The upstream build system adds these dependencies as part of a list
+ # autogenerated during the build of monero. We don't want to have
+ # to build monero just to build the wallet.
+ patch -p1 < ../0001-pro-add-libusb-1.0-to-non-static-link-for-Linux.patch
+ patch -p1 < ../0002-pro-add-protobuf-lib-to-link-commnad-for-Linux.patch
}
build() {
@@ -60,3 +65,7 @@ package() {
install -D -m755 "$srcdir/$_srcdir/release/bin/monero-wallet-gui" "$pkgdir/usr/bin/monero-wallet-qt"
install -D -m644 "$srcdir/$_srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+
+sha256sums=('SKIP'
+ '68de913110996c232a284004057f2655c1798472670e31524f86b005f6bf07a8'
+ '76fbeb62810f9f0281320e5b5309395d3239f1dcb8f08b71b98e8a4c06e33e98')