summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVirgil Dupras2015-06-08 21:49:17 +0000
committerVirgil Dupras2015-06-08 21:49:17 +0000
commit2828162ac70c8498b911302e4ce0e61d3f0af1b5 (patch)
treec69c3383d8880a2a62d21ff37e36b27f58d995dc
downloadaur-2828162ac70c8498b911302e4ce0e61d3f0af1b5.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD38
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..372438a10889
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = moneyguru
+ pkgdesc = Personal finance management application
+ pkgver = 2.8.2
+ pkgrel = 1
+ url = http://www.hardcoded.net/moneyguru/
+ arch = any
+ license = BSD
+ depends = python
+ depends = python-pyqt4
+ source = http://download.hardcoded.net/moneyguru-src-2.8.2.tar.gz
+ md5sums = c4f1b9d21d22306a4124135356de4548
+
+pkgname = moneyguru
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a614f7a7367a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Virgil Dupras <hsoft@hardcoded.net>
+pkgname=moneyguru
+pkgver=2.8.2
+pkgrel=1
+pkgdesc="Personal finance management application"
+arch=(any)
+url="http://www.hardcoded.net/moneyguru/"
+license=('BSD')
+depends=('python' 'python-pyqt4')
+makedepends=(
+)
+source=(http://download.hardcoded.net/$pkgname-src-$pkgver.tar.gz)
+md5sums=('c4f1b9d21d22306a4124135356de4548')
+
+build() {
+ cd "$srcdir"
+ ./bootstrap.sh
+ msg "Starting build..."
+ . env/bin/activate
+ python configure.py
+ python build.py --clean
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "${pkgdir}/usr/share/applications"
+ cp "debian/${pkgname}.desktop" "${pkgdir}/usr/share/applications"
+
+ python package.py
+ cd "build/${pkgname}-arch"
+
+ mkdir -p "$pkgdir/usr/share/${pkgname}"
+ cp -a * "$pkgdir/usr/share/${pkgname}/"
+ chmod a+x "$pkgdir/usr/share/${pkgname}/run.py"
+
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s ../share/${pkgname}/run.py "$pkgdir/usr/bin/${pkgname}"
+}