summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Dünkelmann2020-08-23 01:57:05 +0200
committerMartin Dünkelmann2020-08-23 01:57:39 +0200
commit4a9520c1a1bb7cf127f389daf88eb5260dbf464d (patch)
treef586340775a87cdcdea26fd0b314530426c8b69f
parent975e6ffaffeae847efa1b288da051a430f6aca7c (diff)
downloadaur-4a9520c1a1bb7cf127f389daf88eb5260dbf464d.tar.gz
Fixed build errors & optimized build script
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ee7d296ca42..c68bff9a10b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = moneymanagerex-git
pkgdesc = MoneyManagerEx is an easy-to-use personal finance suite. This package will always point to the newest stable version.
pkgver = 1.3.5
- pkgrel = 3
+ pkgrel = 5
url = http://www.moneymanagerex.org/
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 94d61dc4178b..1b96b3dcdbd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=moneymanagerex-git
_gitname=moneymanagerex
pkgver=1.3.5
-pkgrel=3
+pkgrel=5
pkgdesc="MoneyManagerEx is an easy-to-use personal finance suite. This package will always point to the newest stable version."
arch=('x86_64')
url="http://www.moneymanagerex.org/"
@@ -17,11 +17,11 @@ optdepends=('cups: for printing support')
replaces=('mmex')
provides=('moneymanagerex')
conflicts=('moneymanagerex')
-source=(git+https://github.com/moneymanagerex/moneymanagerex.git#tag=v1.3.5)
+source=(git+https://github.com/moneymanagerex/moneymanagerex.git#tag=v$pkgver)
sha256sums=('SKIP')
prepare() {
- cd "$pkgname"
+ cd "$_gitname"
mkdir -p build
git submodule update --init
# TODO Workaround: https://github.com/moneymanagerex/moneymanagerex/issues/2685
@@ -29,13 +29,13 @@ prepare() {
}
build() {
- cd cd "$pkgname/build"
+ cd "$_gitname/build"
cmake -DCMAKE_BUILD_TYPE=Release -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 ..
cmake --build . --target package
}
package() {
- cd "$pkgname/build"
+ cd "$_gitname/build"
make DESTDIR="${pkgdir}" install
}