summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Dünkelmann2022-05-28 01:25:36 +0200
committerMartin Dünkelmann2022-05-28 01:25:36 +0200
commit7f2a4abf1c3f01e095a638c83185db6f9a333102 (patch)
tree4456a0dbb438f42b45e3c1ea19b23d80c76b1a3d
parentd51841fa33ab031e3e81d2a75fd1fce9502fe6f7 (diff)
downloadaur-7f2a4abf1c3f01e095a638c83185db6f9a333102.tar.gz
switch wxWidgets dependency to wxgtk3-dev-opt
this fixes conflicts with wxWidgets 3.0.x and depending applications Thank you @moritzhoewer for the fix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6dbe7820ca4a..a5fa55be22b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = moneymanagerex-git
pkgdesc = MoneyManagerEx is an easy-to-use personal finance suite. This package will always point to the newest tagged version.
- pkgver = 1.5.13
+ pkgver = 1.5.14
pkgrel = 1
url = http://www.moneymanagerex.org/
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = moneymanagerex-git
makedepends = make
makedepends = pkg-config
makedepends = rapidjson
- depends = wxgtk3-dev
+ depends = wxgtk3-dev-opt
depends = webkit2gtk
optdepends = cups: for printing support
provides = moneymanagerex
diff --git a/PKGBUILD b/PKGBUILD
index 8fada4c2e14f..d0c6a63819b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
# Contributor: TDY <tdy@gmx.com>
pkgname=moneymanagerex-git
-pkgver=1.5.13
+pkgver=1.5.14
pkgrel=1
pkgdesc="MoneyManagerEx is an easy-to-use personal finance suite. This package will always point to the newest tagged version."
arch=('x86_64')
url="http://www.moneymanagerex.org/"
license=('GPL')
-depends=('wxgtk3-dev' 'webkit2gtk')
+depends=('wxgtk3-dev-opt' 'webkit2gtk')
makedepends=('curl' 'cmake' 'fakeroot' 'file' 'gawk' 'gcc' 'gettext' 'git' 'jq' 'lsb-release' 'make' 'pkg-config' 'rapidjson')
optdepends=('cups: for printing support')
replaces=('mmex')
@@ -34,7 +34,12 @@ prepare() {
build() {
cd "${srcdir}"/moneymanagerex
- cmake -DCMAKE_BUILD_TYPE=Release -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 .
+ # Disable all warnings when building, then configure CMake
+ export CXXFLAGS=-w
+ cmake -DCMAKE_BUILD_TYPE=Release -DwxWidgets_CONFIG_EXECUTABLE=/opt/wxgtk-dev/bin/wx-config-gtk3 .
+
+ # Make sure the linker bakes the non-standard path for wxWidgets into the executable
+ export LD_RUN_PATH=/opt/wxgtk-dev/lib
cmake --build . --target package
}