summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Dünkelmann2020-08-23 01:57:05 +0200
committerMartin Dünkelmann2020-08-24 11:33:26 +0200
commit29bd709feac73b8b82b056c6c24fab43c93c3b9a (patch)
treebe23ab9855aca03028216bb2f89501ad81b85dea
parent4a9520c1a1bb7cf127f389daf88eb5260dbf464d (diff)
downloadaur-29bd709feac73b8b82b056c6c24fab43c93c3b9a.tar.gz
Removed unneeded variable in build script
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c68bff9a10b1..f2936e16873b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = moneymanagerex-git
pkgdesc = MoneyManagerEx is an easy-to-use personal finance suite. This package will always point to the newest stable version.
pkgver = 1.3.5
- pkgrel = 5
+ pkgrel = 6
url = http://www.moneymanagerex.org/
arch = x86_64
license = GPL
@@ -26,4 +26,3 @@ pkgbase = moneymanagerex-git
sha256sums = SKIP
pkgname = moneymanagerex-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 1b96b3dcdbd3..e566b90455d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,8 @@
# Contributor: TDY <tdy@gmx.com>
pkgname=moneymanagerex-git
-_gitname=moneymanagerex
pkgver=1.3.5
-pkgrel=5
+pkgrel=6
pkgdesc="MoneyManagerEx is an easy-to-use personal finance suite. This package will always point to the newest stable version."
arch=('x86_64')
url="http://www.moneymanagerex.org/"
@@ -21,7 +20,7 @@ source=(git+https://github.com/moneymanagerex/moneymanagerex.git#tag=v$pkgver)
sha256sums=('SKIP')
prepare() {
- cd "$_gitname"
+ cd "${pkgname%-git}"
mkdir -p build
git submodule update --init
# TODO Workaround: https://github.com/moneymanagerex/moneymanagerex/issues/2685
@@ -29,13 +28,13 @@ prepare() {
}
build() {
- cd "$_gitname/build"
+ cd "${pkgname%-git}/build"
cmake -DCMAKE_BUILD_TYPE=Release -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 ..
cmake --build . --target package
}
package() {
- cd "$_gitname/build"
+ cd "${pkgname%-git}/build"
make DESTDIR="${pkgdir}" install
}