summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMonika Schrenk2016-09-20 14:12:27 +0200
committerMonika Schrenk2016-09-20 14:12:27 +0200
commit97e2eb30a279fba61fce6f6d0dc9e1c772fff7b8 (patch)
treee5a5036a82adef8f93845e2ee3ca3262820ac765
parentaa36e750e697a477beed27e48f9d32defc571bc6 (diff)
downloadaur-97e2eb30a279fba61fce6f6d0dc9e1c772fff7b8.tar.gz
Updated to version 4.2.0; adjusted mongochef sh script
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD8
-rw-r--r--mongochef38
3 files changed, 13 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ba261e02b55..4bd80b1c9fc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Aug 28 21:32:15 UTC 2016
pkgbase = mongochef
pkgdesc = A free universal database tool for developers and database administrators
- pkgver = 4.1.1
+ pkgver = 4.2.0
pkgrel = 1
url = http://3t.io/mongochef/
arch = i686
@@ -15,11 +13,11 @@ pkgbase = mongochef
source = mongochef.desktop
source = mongochef
sha256sums = a603fd54a34f8aa59a70580fd4321db24f439ceb746545f1cf6c0216f7f8169e
- sha256sums = c5a11c0eff26dfdcff7d9ddfaa11201d7d436072d2b217853e81049b99ca677c
- source_i686 = https://cdn.3t.io/mongochef-core/linux/4.1.1/mongochef-linux-x86-dist.tar.gz
- sha256sums_i686 = 79fc478fa895c30e62688c13c4da45e62e3f2c0d95da962e54ae411371f22f5f
- source_x86_64 = https://cdn.3t.io/mongochef-core/linux/4.1.1/mongochef-linux-x64-dist.tar.gz
- sha256sums_x86_64 = 24adc08ffd5683d7979499bde540516ea2f495287bfb70390b728014f7eedd4f
+ sha256sums = 3b03d036ccfa0e25b3f797a8f9fd6076b7b6dd131ab04879cb92d5aa130b8df1
+ source_i686 = https://cdn.3t.io/mongochef-core/linux/4.2.0/mongochef-linux-x86-dist.tar.gz
+ sha256sums_i686 = c8babad9e6407d848a619b255738c430a1a3f2870a020f050ab10d08b958c88d
+ source_x86_64 = https://cdn.3t.io/mongochef-core/linux/4.2.0/mongochef-linux-x64-dist.tar.gz
+ sha256sums_x86_64 = 28abfc3bb10aff41ffbd2374223b6e00f52a524d9f983320d0e8affaa349c804
pkgname = mongochef
diff --git a/PKGBUILD b/PKGBUILD
index ac2ccb8d169f..729067567caa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Monika Schrenk <moni@random-access.org>
pkgname=mongochef
-pkgver=4.1.1
+pkgver=4.2.0
pkgrel=1
pkgdesc="A free universal database tool for developers and database administrators"
arch=('i686' 'x86_64')
@@ -16,9 +16,9 @@ source_i686=("https://cdn.3t.io/mongochef-core/linux/${pkgver}/mongochef-linux-x
source_x86_64=("https://cdn.3t.io/mongochef-core/linux/${pkgver}/mongochef-linux-x64-dist.tar.gz")
sha256sums=('a603fd54a34f8aa59a70580fd4321db24f439ceb746545f1cf6c0216f7f8169e'
-'c5a11c0eff26dfdcff7d9ddfaa11201d7d436072d2b217853e81049b99ca677c')
-sha256sums_i686=('79fc478fa895c30e62688c13c4da45e62e3f2c0d95da962e54ae411371f22f5f')
-sha256sums_x86_64=('24adc08ffd5683d7979499bde540516ea2f495287bfb70390b728014f7eedd4f')
+'3b03d036ccfa0e25b3f797a8f9fd6076b7b6dd131ab04879cb92d5aa130b8df1')
+sha256sums_i686=('c8babad9e6407d848a619b255738c430a1a3f2870a020f050ab10d08b958c88d')
+sha256sums_x86_64=('28abfc3bb10aff41ffbd2374223b6e00f52a524d9f983320d0e8affaa349c804')
prepare() {
unzip -j ${srcdir}/${pkgname}-${pkgver}-linux-*-dist/lib/data-man-gui-1.0-SNAPSHOT.jar "t3/dataman/icons/mc-512.png" -d "./"
diff --git a/mongochef b/mongochef
index ca3bae711450..924b472d3f52 100644
--- a/mongochef
+++ b/mongochef
@@ -15,41 +15,9 @@ else
echo "Using JDK / JRE 8 at "$JDK_PATH" for mongochef execution."
fi
-
-# Decide whether to use GTK2 or GTK3 based
-# on KDE being used or not
-# PURPOSE: Avoid crash due to bug in oxygen-gtk theme engine
-if [ "$1" = "useGtk2" ]; then
- desktop="don't care"
- useGtk2="yes"
-else
- desktop=""
- ps -e | grep -E '^.* kded4$' > /dev/null
- if [ $? -eq 0 ]; then
- desktop="KDE"
- elif [ -n "$XDG_DATA_DIRS" ]; then
- desktop=$XDG_DATA_DIRS
- elif [ -n "$XDG_CURRENT_DESKTOP" ]; then
- desktop=$XDG_CURRENT_DESKTOP
- elif [ -n "$DESKTOP_SESSION" ]; then
- desktop=$DESKTOP_SESSION
- fi
-
- echo $desktop | grep -i KDE > /dev/null
- if [ $? -eq 0 ]; then
- desktop="KDE"
- useGtk2="no"
- else
- useGtk2="yes"
- desktop="not KDE"
- fi
-fi
-
-if [ "$useGtk2" = "yes" ]; then
- # as workaround for https://bugs.eclipse.org/bugs/show_bug.cgi?id=435773
- export SWT_GTK3=0
-fi
+# JavaFX charts rendering requires this to be set.
+export SWT_GTK3=0
# Launch the java program
-$JDK_PATH -jar /opt/mongochef/data-man-mongodb-core-*.jar
+$JDK_PATH -Dprism.order=sw -jar /opt/mongochef/data-man-mongodb-core-*.jar