summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2017-10-16 20:25:09 +0200
committerMattias Andrée2017-10-16 20:25:09 +0200
commitf1562232a04f5fcb05b254da8dd2f8dd6acca5b5 (patch)
tree4c612f1c2c35b4d5a23fba89fd85872877bc7b1c
parent2cf45e1f0651540efab9fae721674a3172b15eeb (diff)
downloadaur-f1562232a04f5fcb05b254da8dd2f8dd6acca5b5.tar.gz
Update to 2.3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9371222ba24d..f52773e7472f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
+# Generated by mksrcinfo v8
+# Mon Oct 16 18:25:09 UTC 2017
pkgbase = mongoclock
pkgdesc = Just a humongous clock for the terminal
- pkgver = 2.2
- pkgrel = 2
+ pkgver = 2.3
+ pkgrel = 1
url = https://github.com/maandree/mongoclock
- install = mongoclock.install
arch = any
- license = GPL3
- makedepends = linux-api-headers
- makedepends = general-preprocessor
- makedepends = texinfo
- depends = glibc
- depends = linux
- source = https://github.com/maandree/mongoclock/archive/2.2.tar.gz
- sha256sums = ae2298905a2f729679fddaeb732183b95607438af62dca02bdf5ae0a1b29e950
+ license = ISC
+ source = mongoclock-2.3.tar.gz::https://github.com/maandree/mongoclock/archive/2.3.tar.gz
+ sha256sums = 38a438cb3441681621c38eca2047e7504724fbb12da8ac6c60316aaeebc0f95f
pkgname = mongoclock
diff --git a/PKGBUILD b/PKGBUILD
index b77c0ed808c4..154080396617 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,21 @@
-# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
pkgname=mongoclock
-pkgver=2.2
-pkgrel=2
+pkgver=2.3
+pkgrel=1
pkgdesc='Just a humongous clock for the terminal'
arch=(any)
url='https://github.com/maandree/mongoclock'
-license=('GPL3')
-depends=(glibc linux)
-makedepends=(linux-api-headers general-preprocessor texinfo)
-install=mongoclock.install
-source=("${url}/archive/${pkgver}.tar.gz")
-sha256sums=(ae2298905a2f729679fddaeb732183b95607438af62dca02bdf5ae0a1b29e950)
-
+license=('ISC')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=(38a438cb3441681621c38eca2047e7504724fbb12da8ac6c60316aaeebc0f95f)
build() {
cd "$srcdir/mongoclock-$pkgver"
- make
+ make PREFIX=/usr
}
package() {
cd "$srcdir/mongoclock-$pkgver"
- make DESTDIR="${pkgdir}" install
+ make PREFIX=/usr DESTDIR="$pkgdir" install
}
-