summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAli Molaei2019-02-14 19:26:50 +0330
committerAli Molaei2019-02-14 19:26:50 +0330
commitea66462251df988d53e83574e050cd0f0e2c2e2e (patch)
treeee9715d1d74e06e1d9350c3ca0a5353f0ae11d5a
parent764a0f78ca3fd8be0ad26204d2123afb5a5a6b47 (diff)
downloadaur-ea66462251df988d53e83574e050cd0f0e2c2e2e.tar.gz
Use ubuntu xenial debs instead of general linux binaries of mongodb, due to not supporting ssl and being removed after version 4.2, https://www.mongodb.com/blog/post/a-proposal-to-endoflife-our-generic-linux-tar-packages, also separate -tools package from this package
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD44
3 files changed, 43 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3da72964f1ac..dde833072b7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,30 @@
pkgbase = mongodb-bin
pkgdesc = A high-performance, open source, schema-free document-oriented database
pkgver = 4.0.6
- pkgrel = 3
+ pkgrel = 4
url = https://www.mongodb.com/
arch = x86_64
license = SSPLv1
- optdepends = libpcap: Needed for mongoreplay
- optdepends = mongodb-compass: The MongoDB GUI
+ optdepends = mongodb-tools: The MongoDB tools provide import, export, and diagnostic capabilities.
provides = mongodb=4.0.6
- provides = mongodb-tools=4.0.6
conflicts = mongodb
- conflicts = mongodb-tools
backup = etc/mongodb.conf
- source = https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-4.0.6.tgz
+ source = https://repo.mongodb.org/apt/ubuntu/dists/bionic/mongodb-org/4.0/multiverse/binary-amd64/mongodb-org-shell_4.0.6_amd64.deb
+ source = https://repo.mongodb.org/apt/ubuntu/dists/bionic/mongodb-org/4.0/multiverse/binary-amd64/mongodb-org-server_4.0.6_amd64.deb
+ source = https://repo.mongodb.org/apt/ubuntu/dists/bionic/mongodb-org/4.0/multiverse/binary-amd64/mongodb-org-mongos_4.0.6_amd64.deb
source = mongodb.service
source = mongodb.conf
source = mongodb.sysusers
source = mongodb.tmpfiles
source = LICENSE
- md5sums = 1639ef8b9545c3120ac2b7cd7714b995
- md5sums = 96ab4517b48974ce0e566d9746a75a4f
- md5sums = 4839fe1d638187ca3226e8267b947318
- md5sums = ff773b723f7bf217c2a8176e3b143498
- md5sums = c599936e8858aeba31dc06cc3ff88612
- md5sums = 3a865f27f11f43ecbe542d9ea387dcf1
+ sha256sums = 0732fadef967ec2a1d3fc96d85c4c631e3b53560fbaa5a9c2e8e8493244d9e1c
+ sha256sums = 298268d803211f87c66f1f16f378de198a8142f4abe34589f2354c775a8bf0b1
+ sha256sums = c7238d4c080fe7a52ae3569572da4e9eb32d35b586b3c3222d957810c9a27f29
+ sha256sums = 19f55ab28652b3817e98fc3f15cc2f6f3255a5e1dfd7b0d5a27c9ba22fd2703e
+ sha256sums = 8010ce728d657524cd76b5afda7ffbc1cc389642336b12b89cec5df2b09fc0e4
+ sha256sums = 47b884569102f7c79017ee78ef2e98204a25aa834c0ee7d5d62c270ab05d4e2b
+ sha256sums = 51ee1e1f71598aad919db79a195778e6cb6cfce48267565e88a401ebc64497ac
+ sha256sums = 09d99ca61eb07873d5334077acba22c33e7f7d0a9fa08c92734e0ac8430d6e27
pkgname = mongodb-bin
diff --git a/.gitignore b/.gitignore
index 08d7058281b3..3d1be99065fb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
/mongodb-bin-*
-/mongodb-linux-*
+/mongodb-org-*
/src/
/pkg/
pkg/
diff --git a/PKGBUILD b/PKGBUILD
index 993eb39bb022..6a3751d8201b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,54 @@
pkgname="mongodb-bin"
pkgver="4.0.6"
-pkgrel="3"
+basever="4.0"
+pkgrel="4"
pkgdesc="A high-performance, open source, schema-free document-oriented database"
arch=("x86_64")
url="https://www.mongodb.com/"
license=("SSPLv1")
-provides=("mongodb=$pkgver" "mongodb-tools=$pkgver")
-conflicts=("mongodb" "mongodb-tools")
-optdepends=('libpcap: Needed for mongoreplay'
- 'mongodb-compass: The MongoDB GUI')
+provides=("mongodb=$pkgver")
+conflicts=("mongodb")
+optdepends=("mongodb-tools: The MongoDB tools provide import, export, and diagnostic capabilities.")
source=(
- "https://fastdl.mongodb.org/linux/mongodb-linux-$arch-$pkgver.tgz"
+ "https://repo.mongodb.org/apt/ubuntu/dists/bionic/mongodb-org/${basever}/multiverse/binary-amd64/mongodb-org-shell_${pkgver}_amd64.deb"
+ "https://repo.mongodb.org/apt/ubuntu/dists/bionic/mongodb-org/${basever}/multiverse/binary-amd64/mongodb-org-server_${pkgver}_amd64.deb"
+ "https://repo.mongodb.org/apt/ubuntu/dists/bionic/mongodb-org/${basever}/multiverse/binary-amd64/mongodb-org-mongos_${pkgver}_amd64.deb"
"mongodb.service"
"mongodb.conf"
"mongodb.sysusers"
"mongodb.tmpfiles"
"LICENSE")
-md5sums=('1639ef8b9545c3120ac2b7cd7714b995'
- '96ab4517b48974ce0e566d9746a75a4f'
- '4839fe1d638187ca3226e8267b947318'
- 'ff773b723f7bf217c2a8176e3b143498'
- 'c599936e8858aeba31dc06cc3ff88612'
- '3a865f27f11f43ecbe542d9ea387dcf1')
+sha256sums=("0732fadef967ec2a1d3fc96d85c4c631e3b53560fbaa5a9c2e8e8493244d9e1c"
+ "298268d803211f87c66f1f16f378de198a8142f4abe34589f2354c775a8bf0b1"
+ "c7238d4c080fe7a52ae3569572da4e9eb32d35b586b3c3222d957810c9a27f29"
+ "19f55ab28652b3817e98fc3f15cc2f6f3255a5e1dfd7b0d5a27c9ba22fd2703e"
+ "8010ce728d657524cd76b5afda7ffbc1cc389642336b12b89cec5df2b09fc0e4"
+ "47b884569102f7c79017ee78ef2e98204a25aa834c0ee7d5d62c270ab05d4e2b"
+ "51ee1e1f71598aad919db79a195778e6cb6cfce48267565e88a401ebc64497ac"
+ "09d99ca61eb07873d5334077acba22c33e7f7d0a9fa08c92734e0ac8430d6e27")
backup=("etc/mongodb.conf")
+prepare() {
+ cd "${srcdir}"
+ mkdir -p "${srcdir}/output"
+ tar -xvf "${srcdir}/data.tar.xz" -C "${srcdir}/output" #mongos extracted
+ ar x mongodb-org-server_${pkgver}_amd64.deb
+ tar -xvf "${srcdir}/data.tar.xz" -C "${srcdir}/output" #server extracted
+ ar x mongodb-org-shell_${pkgver}_amd64.deb
+ tar -xvf "${srcdir}/data.tar.xz" -C "${srcdir}/output" #shell extracted
+}
+
package() {
mkdir -p "$pkgdir/usr"
- cp -r "$srcdir/mongodb-linux-$arch-$pkgver/bin" "$pkgdir/usr/"
- rm "$pkgdir/usr/bin/install_compass"
+ mkdir -p "$pkgdir/usr/share/man"
+ cp -r "$srcdir/output/usr/bin" "$pkgdir/usr/"
+ cp -r "$srcdir/output/usr/share/man/man1" "$pkgdir/usr/share/man/"
install -Dm644 "$srcdir/mongodb.conf" "$pkgdir/etc/mongodb.conf"
install -Dm644 "$srcdir/mongodb.service" "$pkgdir/usr/lib/systemd/system/mongodb.service"
install -Dm644 "$srcdir/mongodb.sysusers" "$pkgdir/usr/lib/sysusers.d/mongodb.conf"
install -Dm644 "$srcdir/mongodb.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/mongodb.conf"
install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-