summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÓscar García Amor2017-04-03 11:15:12 +0200
committerÓscar García Amor2017-04-03 11:15:12 +0200
commit9cfa400a091ce8f9cb3cc4c1718857f35a6a80f1 (patch)
tree6adc4e46b607676b2f4732a3324bcfcea03242a4
downloadaur-9cfa400a091ce8f9cb3cc4c1718857f35a6a80f1.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12472983ac37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = mongodb-compass
+ pkgdesc = The MongoDB GUI
+ pkgver = 1.6.2
+ pkgrel = 1
+ url = https://www.mongodb.com/products/compass
+ arch = x86_64
+ license = custom
+ depends = alsa-lib
+ depends = expat
+ depends = gconf
+ depends = gtk2
+ depends = gvfs
+ depends = hunspell
+ depends = hunspell-en
+ depends = libcurl-compat
+ depends = libgcrypt
+ depends = libgnome-keyring
+ depends = libnotify
+ depends = libxss
+ depends = libxtst
+ depends = xdg-utils
+ optdepends = gnome-keyring
+ source = https://downloads.mongodb.com/compass/mongodb-compass_1.6.2_amd64.deb
+ sha256sums = 2a87f7cfaaadde1ad35b1373c120c2c0474d85808d8b35b5548519df8730e573
+
+pkgname = mongodb-compass
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa88efccaf3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
+
+pkgname=mongodb-compass
+pkgver=1.6.2
+pkgrel=1
+pkgdesc="The MongoDB GUI"
+arch=('x86_64')
+url="https://www.mongodb.com/products/compass"
+license=('custom')
+depends=('alsa-lib' 'expat' 'gconf' 'gtk2' 'gvfs' 'hunspell' 'hunspell-en' 'libcurl-compat' 'libgcrypt' 'libgnome-keyring' 'libnotify' 'libxss' 'libxtst' 'xdg-utils')
+optdepends=('gnome-keyring')
+source=("https://downloads.mongodb.com/compass/${pkgname}_${pkgver}_amd64.deb")
+sha256sums=('2a87f7cfaaadde1ad35b1373c120c2c0474d85808d8b35b5548519df8730e573')
+
+package() {
+ bsdtar -O -xf "${pkgname}_${pkgver}"*.deb data.tar.xz | bsdtar -C "$pkgdir" -xJf -
+
+ # Permission fix
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+
+ # Remove all unnecessary stuff
+ rm -rf "${pkgdir}/usr/share/lintian"
+ rm -rf "${pkgdir}/usr/share/doc"
+
+ # Install license
+ install -dm755 ${pkgdir}/usr/share/licenses/${pkgname}
+ ln -s /usr/share/${pkgname}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}
+}