summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-07-08 10:57:58 +0200
committerDaniel Peukert2023-07-08 10:57:58 +0200
commit5d90e74a39f15e78bda19a962d0a8caaf7feac94 (patch)
treeae7a2c33712c44620d2b27777a84c38f0d138e8f
parent8e4434847a447f35677f489469eaa3b32f0a7d20 (diff)
downloadaur-5d90e74a39f15e78bda19a962d0a8caaf7feac94.tar.gz
Update mongodb-compass npm dep
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 2 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa2d388ad1b4..edb526b9124d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,7 @@ pkgbase = mongodb-compass-beta
license = custom:SSPL
makedepends = git
makedepends = nodejs>=16.15.1
- makedepends = npm>=8.19.2
+ makedepends = npm>=8.19.4
makedepends = python
makedepends = unzip
depends = electron23
diff --git a/PKGBUILD b/PKGBUILD
index f636a1497575..0d7bb379cce3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ url='https://www.mongodb.com/products/compass'
license=('custom:SSPL')
_electronpkg='electron23'
depends=("$_electronpkg" 'krb5' 'libsecret' 'lsb-release')
-makedepends=('git' 'nodejs>=16.15.1' 'npm>=8.19.2' 'python' 'unzip')
+makedepends=('git' 'nodejs>=16.15.1' 'npm>=8.19.4' 'python' 'unzip')
optdepends=('org.freedesktop.secrets')
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/mongodb-js/compass/archive/v$_pkgver.tar.gz"
@@ -34,9 +34,6 @@ prepare() {
# Disable husky command
sed -i '/husky install/d' 'package.json'
- # Loosen npm version restriction until the version of npm in repos is updated to >= 8.19.4
- sed -E -i "s|\"npm\": \">=8.19.4\"|\"npm\": \">=$(npm -v)\"|" 'package.json' 'package-lock.json'
-
# Set system Electron version for ABI compatibility
sed -E -i 's|("electron": ").*"|\1'"$(cat "/usr/lib/$_electronpkg/version")"'"|' {'configs','packages'}'/'*'/package.json'