summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2018-06-26 22:33:51 +0200
committerDaniel Peukert2018-06-26 22:33:51 +0200
commitb5cb68e8ae92de1727b43e4596c6408cf6aca465 (patch)
tree4ca4a2a65a0aea526a257a3b7c79849978304f8d
downloadaur-b5cb68e8ae92de1727b43e4596c6408cf6aca465.tar.gz
Updated to 1.14.5
-rw-r--r--.SRCINFO22
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD20
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31803b8b1cd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = mongodb-compass-community
+ pkgdesc = The official GUI for MongoDB - Community Edition
+ pkgver = 1.14.5
+ pkgrel = 1
+ url = https://www.mongodb.com/products/compass
+ arch = x86_64
+ license = custom
+ depends = nss
+ depends = gconf
+ depends = libxtst
+ depends = alsa-lib
+ depends = gtk2
+ depends = libsecret
+ depends = gcc-libs-multilib
+ depends = libxss
+ optdepends = gnome-keyring
+ optdepends = libgnome-keyring
+ source = https://downloads.mongodb.com/compass/mongodb-compass-community-1.14.5.x86_64.rpm
+ md5sums = a460e6a97460a7d4b8992b2302fe403e
+
+pkgname = mongodb-compass-community
+
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c1a5245d7cfa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1351ae22695
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+pkgname='mongodb-compass-community'
+pkgver='1.14.5'
+pkgrel='1'
+pkgdesc='The official GUI for MongoDB - Community Edition'
+arch=('x86_64')
+url='https://www.mongodb.com/products/compass'
+license=('custom')
+depends=('nss' 'gconf' 'libxtst' 'alsa-lib' 'gtk2' 'libsecret' 'gcc-libs-multilib' 'libxss')
+optdepends=('gnome-keyring' 'libgnome-keyring')
+source=('https://downloads.mongodb.com/compass/mongodb-compass-community-1.14.5.x86_64.rpm')
+md5sums=('a460e6a97460a7d4b8992b2302fe403e')
+
+package() {
+ rm -r "$srcdir/usr/share/doc/"
+ mkdir -p "$srcdir/usr/share/licenses/mongodb-compass-community"
+ mv "$srcdir/usr/share/mongodb-compass-community/LICENSE"* "$srcdir/usr/share/licenses/mongodb-compass-community"
+
+ cp -r --preserve=mode "$srcdir/usr/" "$pkgdir/usr/"
+}