summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-02-26 21:53:29 +0100
committerDaniel Peukert2020-02-26 21:53:29 +0100
commit7f457f099227137d8a9ff348f42ba01c2448a026 (patch)
tree552c47f9713eaee10c7f6890500cce6207ec4450
parent027438831f2ecb4e49e3f1c4bcdcd541cc4a6f4c (diff)
downloadaur-7f457f099227137d8a9ff348f42ba01c2448a026.tar.gz
Updated mongodb-compass-bin to just use the provided binary
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD31
-rw-r--r--launch.sh2
3 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1695e1b3189..8b1a89132da2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = mongodb-compass-community-bin
pkgdesc = The official GUI for MongoDB - Community Edition - binary version
pkgver = 1.20.5
- pkgrel = 1
+ pkgrel = 2
url = https://www.mongodb.com/products/compass
arch = x86_64
license = custom:SSPL
- depends = electron3-bin
depends = krb5
depends = libsecret
provides = mongodb-compass-community
conflicts = mongodb-compass-community
- source = mongodb-compass-community-bin-1.20.5-1.rpm::https://github.com/mongodb-js/compass/releases/download/v1.20.5/mongodb-compass-community-1.20.5.x86_64.rpm
- source = launch.sh
+ source = mongodb-compass-community-bin-1.20.5-2.rpm::https://github.com/mongodb-js/compass/releases/download/v1.20.5/mongodb-compass-community-1.20.5.x86_64.rpm
sha256sums = 03e5b05159a53576f100be48e371f27b5952b34e3eb4584548efb9516b61af7f
- sha256sums = 1bf3dd5e9363e750f4099acab9c8e22af7dc8645215d3fc4ed13abb0d38c5137
pkgname = mongodb-compass-community-bin
diff --git a/PKGBUILD b/PKGBUILD
index 75489dd9ef07..f8e0aae51a62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,34 @@
# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
_pkgname='mongodb-compass-community'
+_edition=' Community'
pkgname="$_pkgname-bin"
_pkgver='1.20.5'
pkgver="$(printf '%s' "$_pkgver" | tr '-' '.')"
-pkgrel='1'
+pkgrel='2'
pkgdesc='The official GUI for MongoDB - Community Edition - binary version'
arch=('x86_64')
url='https://www.mongodb.com/products/compass'
license=('custom:SSPL')
-depends=('electron3-bin' 'krb5' 'libsecret')
+depends=('krb5' 'libsecret')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=(
- "$pkgname-$pkgver-$pkgrel.rpm::https://github.com/mongodb-js/compass/releases/download/v$_pkgver/$_pkgname-$_pkgver.x86_64.rpm"
- 'launch.sh'
-)
-sha256sums=('03e5b05159a53576f100be48e371f27b5952b34e3eb4584548efb9516b61af7f'
- '1bf3dd5e9363e750f4099acab9c8e22af7dc8645215d3fc4ed13abb0d38c5137')
+source=("$pkgname-$pkgver-$pkgrel.rpm::https://github.com/mongodb-js/compass/releases/download/v$_pkgver/$_pkgname-$_pkgver.x86_64.rpm")
+sha256sums=('03e5b05159a53576f100be48e371f27b5952b34e3eb4584548efb9516b61af7f')
package() {
cd "$srcdir/"
- install -Dm644 "usr/share/$_pkgname/resources/app.asar" "$pkgdir/usr/lib/$_pkgname/app.asar"
- install -dm755 "$pkgdir/usr/lib/$_pkgname/"
- cp -r --no-preserve=ownership --preserve=mode "usr/share/$_pkgname/resources/app.asar.unpacked/" "$pkgdir/usr/lib/$_pkgname/app.asar.unpacked/"
- install -Dm755 "launch.sh" "$pkgdir/usr/bin/$_pkgname"
- install -Dm644 "usr/share/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 "usr/share/$_pkgname/LICENSES.chromium.html" "$pkgdir/usr/share/licenses/$pkgname/LICENSES.chromium.html"
+
+ install -dm755 "$pkgdir/opt/"
+ cp -r --no-preserve=ownership --preserve=mode "usr/share/$_pkgname/" "$pkgdir/opt/$_pkgname/"
+
+ install -dm755 "$pkgdir/usr/bin/"
+ ln -sf "/opt/$_pkgname/MongoDB Compass$_edition" "$pkgdir/usr/bin/$_pkgname"
+
install -Dm644 "usr/share/applications/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
install -Dm644 "usr/share/pixmaps/$_pkgname.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
+
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname/"
+ for _license in 'LICENSE' 'LICENSES.chromium.html'; do
+ ln -sf "/opt/$_pkgname/$_license" "$pkgdir/usr/share/licenses/$pkgname/$_license"
+ done
}
diff --git a/launch.sh b/launch.sh
deleted file mode 100644
index 020b276f4f9d..000000000000
--- a/launch.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-exec electron3 "/usr/lib/$(basename "$0")/app.asar" "$@"