summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-10-08 12:01:57 +0200
committerDaniel Peukert2023-10-08 12:01:57 +0200
commit59708072356cb70397602ef28a9f6ffa0da2fab0 (patch)
tree5cec2723ae91fd25930c9c7bbc5289c5e38da129
parent6c27a9f03a1a6229f17b1bb0b0c26c87b4b65183 (diff)
downloadaur-59708072356cb70397602ef28a9f6ffa0da2fab0.tar.gz
Fix mongodb-compass build correctly
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD4
2 files changed, 14 insertions, 18 deletions
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..004b0a3a8706 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index f5703a2e246d..2b59f580e931 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,10 +31,6 @@ _sourcedirectory="compass-$_pkgver"
prepare() {
cd "$srcdir/$_sourcedirectory/"
- # Due to a bug in lerna, having a git repo in the parent directory is not supported (this is the case in some AUR helpers),
- # we init a git repo in our source directory to make sure this doesn't happen
- git init
-
# Disable husky command
sed -i '/husky install/d' 'package.json'