summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2018-06-26 22:34:23 +0200
committerDaniel Peukert2018-06-26 22:34:23 +0200
commit9072aa1ae32cccf20057dd126c1e4a7fd9d6b3f6 (patch)
tree8149ab83d65f3ee02b26c6526979d1b7e522c806
downloadaur-9072aa1ae32cccf20057dd126c1e4a7fd9d6b3f6.tar.gz
Updated to 1.14.5
-rw-r--r--.SRCINFO22
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD20
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11fa3cf2ffa0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = mongodb-compass-isolated
+ pkgdesc = The official GUI for MongoDB - Isolated Edition
+ pkgver = 1.14.5
+ pkgrel = 1
+ url = https://www.mongodb.com/products/compass
+ arch = x86_64
+ license = custom
+ depends = nss
+ depends = gconf
+ depends = libxtst
+ depends = alsa-lib
+ depends = gtk2
+ depends = libsecret
+ depends = gcc-libs-multilib
+ depends = libxss
+ optdepends = gnome-keyring
+ optdepends = libgnome-keyring
+ source = https://downloads.mongodb.com/compass/mongodb-compass-isolated-1.14.5.x86_64.rpm
+ md5sums = eae226b2eba0249bbacec07ef44270d5
+
+pkgname = mongodb-compass-isolated
+
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c1a5245d7cfa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd66f9f37c32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+pkgname='mongodb-compass-isolated'
+pkgver='1.14.5'
+pkgrel='1'
+pkgdesc='The official GUI for MongoDB - Isolated Edition'
+arch=('x86_64')
+url='https://www.mongodb.com/products/compass'
+license=('custom')
+depends=('nss' 'gconf' 'libxtst' 'alsa-lib' 'gtk2' 'libsecret' 'gcc-libs-multilib' 'libxss')
+optdepends=('gnome-keyring' 'libgnome-keyring')
+source=('https://downloads.mongodb.com/compass/mongodb-compass-isolated-1.14.5.x86_64.rpm')
+md5sums=('eae226b2eba0249bbacec07ef44270d5')
+
+package() {
+ rm -r "$srcdir/usr/share/doc/"
+ mkdir -p "$srcdir/usr/share/licenses/mongodb-compass-isolated"
+ mv "$srcdir/usr/share/mongodb-compass-isolated/LICENSE"* "$srcdir/usr/share/licenses/mongodb-compass-isolated"
+
+ cp -r --preserve=mode "$srcdir/usr/" "$pkgdir/usr/"
+}