summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2018-06-26 22:34:05 +0200
committerDaniel Peukert2018-06-26 22:34:05 +0200
commit513fa53495974e3db14e56ccaaf644ac3eae06ac (patch)
tree4e8a7cc63d69aa6391d6819e071f2ec82262cd8e
downloadaur-513fa53495974e3db14e56ccaaf644ac3eae06ac.tar.gz
Updated to 1.14.5
-rw-r--r--.SRCINFO22
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD20
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66c7aea1bd98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = mongodb-compass-readonly
+ pkgdesc = The official GUI for MongoDB - Readonly Edition
+ pkgver = 1.14.5
+ pkgrel = 1
+ url = https://www.mongodb.com/products/compass
+ arch = x86_64
+ license = custom
+ depends = nss
+ depends = gconf
+ depends = libxtst
+ depends = alsa-lib
+ depends = gtk2
+ depends = libsecret
+ depends = gcc-libs-multilib
+ depends = libxss
+ optdepends = gnome-keyring
+ optdepends = libgnome-keyring
+ source = https://downloads.mongodb.com/compass/mongodb-compass-readonly-1.14.5.x86_64.rpm
+ md5sums = 803fab413f9cb9348945664828bfe17e
+
+pkgname = mongodb-compass-readonly
+
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c1a5245d7cfa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..810a0eea4450
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+pkgname='mongodb-compass-readonly'
+pkgver='1.14.5'
+pkgrel='1'
+pkgdesc='The official GUI for MongoDB - Readonly Edition'
+arch=('x86_64')
+url='https://www.mongodb.com/products/compass'
+license=('custom')
+depends=('nss' 'gconf' 'libxtst' 'alsa-lib' 'gtk2' 'libsecret' 'gcc-libs-multilib' 'libxss')
+optdepends=('gnome-keyring' 'libgnome-keyring')
+source=('https://downloads.mongodb.com/compass/mongodb-compass-readonly-1.14.5.x86_64.rpm')
+md5sums=('803fab413f9cb9348945664828bfe17e')
+
+package() {
+ rm -r "$srcdir/usr/share/doc/"
+ mkdir -p "$srcdir/usr/share/licenses/mongodb-compass-readonly"
+ mv "$srcdir/usr/share/mongodb-compass-readonly/LICENSE"* "$srcdir/usr/share/licenses/mongodb-compass-readonly"
+
+ cp -r --preserve=mode "$srcdir/usr/" "$pkgdir/usr/"
+}