summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-04-24 00:12:38 +0200
committerDaniel Peukert2024-04-24 00:12:38 +0200
commit70e225c68c1400bbe117f7b28586b2c171e65d55 (patch)
tree1a8abe9a0c74e0ed46854807e3fb22011b036b66
parentc948f84a81cd0f199da99969333d8d41ffbe603c (diff)
downloadaur-70e225c68c1400bbe117f7b28586b2c171e65d55.tar.gz
Update mongodb-compass-beta to 1.42.6-beta.2 (closes #498)
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21a6c9a73364..781606c25d6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,11 @@ pkgdesc='The official GUI for MongoDB - Readonly Edition'
arch=('x86_64' 'armv7h' 'aarch64')
url='https://www.mongodb.com/products/compass'
license=('SSPL-1.0')
-
-_electronpkg='electron28'
+if [[ "$_target" =~ -beta$ ]]; then
+ _electronpkg='electron29'
+else
+ _electronpkg='electron28'
+fi
depends=("$_electronpkg" 'krb5' 'libsecret' 'lsb-release' 'nodejs>=16.15.1')
makedepends=('git' 'npm>=8.19.4' 'python' 'unzip')
optdepends=('org.freedesktop.secrets')