summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-01-05 20:52:42 +0100
committerDaniel Peukert2020-01-05 20:52:42 +0100
commit0ec86d911180187263db09eb7e49f74212905d1e (patch)
tree7cf1ea03a83952ef469917816ad1bb3e6ee12200
downloadaur-0ec86d911180187263db09eb7e49f74212905d1e.tar.gz
Renamed mongodb-compass-* to mongodb-compass-*-bin
-rw-r--r--.SRCINFO16
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD29
-rw-r--r--launch.sh2
5 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53afe8c8d79a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mongodb-compass-readonly-bin
+ pkgdesc = The official GUI for MongoDB - Readonly Edition - binary version
+ pkgver = 1.20.4
+ pkgrel = 1
+ url = https://www.mongodb.com/products/compass
+ arch = x86_64
+ license = custom:SSPL
+ depends = electron3-bin
+ depends = krb5
+ depends = libsecret
+ source = mongodb-compass-readonly-bin-1.20.4-1.rpm::https://github.com/mongodb-js/compass/releases/download/v1.20.4/mongodb-compass-readonly-1.20.4.x86_64.rpm
+ source = launch.sh
+ sha256sums = 0ea1c300bbc2a97813cf6082cbc1404cb415d43995063c61c687f7ac22801c07
+ sha256sums = 1bf3dd5e9363e750f4099acab9c8e22af7dc8645215d3fc4ed13abb0d38c5137
+
+pkgname = mongodb-compass-readonly-bin
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c5d008a860c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+_pkgname='mongodb-compass-readonly'
+pkgname="$_pkgname-bin"
+_pkgver='1.20.4'
+pkgver="$(printf '%s' "$_pkgver" | tr '-' '.')"
+pkgrel='1'
+pkgdesc='The official GUI for MongoDB - Readonly Edition - binary version'
+arch=('x86_64')
+url='https://www.mongodb.com/products/compass'
+license=('custom:SSPL')
+depends=('electron3-bin' 'krb5' 'libsecret')
+source=(
+ "$pkgname-$pkgver-$pkgrel.rpm::https://github.com/mongodb-js/compass/releases/download/v$_pkgver/$_pkgname-$_pkgver.x86_64.rpm"
+ 'launch.sh'
+)
+sha256sums=('0ea1c300bbc2a97813cf6082cbc1404cb415d43995063c61c687f7ac22801c07'
+ '1bf3dd5e9363e750f4099acab9c8e22af7dc8645215d3fc4ed13abb0d38c5137')
+
+package() {
+ cd "$srcdir/"
+ install -Dm644 "usr/share/$_pkgname/resources/app.asar" "$pkgdir/usr/lib/$_pkgname/app.asar"
+ install -dm755 "$pkgdir/usr/lib/$_pkgname/app.asar.unpacked/"
+ cp -r --no-preserve=ownership --preserve=mode "usr/share/$_pkgname/resources/app.asar.unpacked/"* "$pkgdir/usr/lib/$_pkgname/app.asar.unpacked/"
+ install -Dm755 "launch.sh" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 "usr/share/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "usr/share/$_pkgname/LICENSES.chromium.html" "$pkgdir/usr/share/licenses/$pkgname/LICENSES.chromium.html"
+ install -Dm644 "usr/share/applications/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ install -Dm644 "usr/share/pixmaps/$_pkgname.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
+}
diff --git a/launch.sh b/launch.sh
new file mode 100644
index 000000000000..020b276f4f9d
--- /dev/null
+++ b/launch.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec electron3 "/usr/lib/$(basename "$0")/app.asar" "$@"