summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-08-27 16:45:23 +0200
committerDaniel Peukert2023-08-27 16:45:23 +0200
commitb0b3fb2b14644a1f8c2b4033c1977f6705dfd896 (patch)
tree6c700a4ceaf642ec2681fb9ee33eaee952d20281
parent82ed0effc038a962465963d180840fd79410c89d (diff)
downloadaur-b0b3fb2b14644a1f8c2b4033c1977f6705dfd896.tar.gz
Remove unnecessary mongodb-compass-git build fix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--lerna.diff11
3 files changed, 4 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9148160eed9..5c6197702b00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mongodb-compass-readonly-git
pkgdesc = The official GUI for MongoDB - Readonly Edition - git version
- pkgver = r16151.gccdd2ebe9
+ pkgver = r16152.ga686882b5
pkgrel = 1
epoch = 1
url = https://www.mongodb.com/products/compass
@@ -24,11 +24,9 @@ pkgbase = mongodb-compass-readonly-git
source = hadron-build-ffmpeg.diff
source = hadron-build-os-dns-native.diff
source = fix-argv.diff
- source = lerna.diff
sha512sums = SKIP
sha512sums = ec052448ea2a375941944026b7b5419d48c67c324af5b75647376737a8f0f98f544cb335c948625c2e06f779a52c58ff2996561e1db977146faef4793d41d3e5
sha512sums = e1082fd804ba72ccf3e53576077562f8b159b76e6aa07fa2324e31dd45c0d863d844fbb8be139be427e2cdd0401a2c4b8e6279ee9305c5507fbd73c5bc0df65d
sha512sums = 6621d214ac692f57e0802b7b4ac0c6a5aedf871896d084afb3939abe3b921ca0b4d9895d4fd0d14574e910681e6d17ecbd0ff321ed9f9a18e963d23da6778d0e
- sha512sums = 2ced8f06e82a8ff5639fddb75a638bf9c1d06c8d891dd07c88dd1aa5fa00faf1d07f35f7a7d283abbac68c4ec74c750c9017c793644388c66b8027ab7acb23bd
pkgname = mongodb-compass-readonly-git
diff --git a/PKGBUILD b/PKGBUILD
index 83b4bd4bc16b..67cbf8e5dddf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _target='compass-readonly'
_edition=' Readonly'
_pkgname="mongodb-$_target"
pkgname="$_pkgname-git"
-pkgver='r16151.gccdd2ebe9'
+pkgver='r16152.ga686882b5'
pkgrel='1'
epoch='1'
pkgdesc='The official GUI for MongoDB - Readonly Edition - git version'
@@ -23,13 +23,11 @@ source=(
'hadron-build-ffmpeg.diff'
'hadron-build-os-dns-native.diff'
'fix-argv.diff'
- 'lerna.diff'
)
sha512sums=('SKIP'
'ec052448ea2a375941944026b7b5419d48c67c324af5b75647376737a8f0f98f544cb335c948625c2e06f779a52c58ff2996561e1db977146faef4793d41d3e5'
'e1082fd804ba72ccf3e53576077562f8b159b76e6aa07fa2324e31dd45c0d863d844fbb8be139be427e2cdd0401a2c4b8e6279ee9305c5507fbd73c5bc0df65d'
- '6621d214ac692f57e0802b7b4ac0c6a5aedf871896d084afb3939abe3b921ca0b4d9895d4fd0d14574e910681e6d17ecbd0ff321ed9f9a18e963d23da6778d0e'
- '2ced8f06e82a8ff5639fddb75a638bf9c1d06c8d891dd07c88dd1aa5fa00faf1d07f35f7a7d283abbac68c4ec74c750c9017c793644388c66b8027ab7acb23bd')
+ '6621d214ac692f57e0802b7b4ac0c6a5aedf871896d084afb3939abe3b921ca0b4d9895d4fd0d14574e910681e6d17ecbd0ff321ed9f9a18e963d23da6778d0e')
_sourcedirectory="$pkgname"
@@ -55,14 +53,11 @@ prepare() {
# Apply argv fixes
patch --forward -p1 < "$srcdir/fix-argv.diff"
- # Running lerna with the new Nx task runner enabled causes the build to fail when not running in a clean chroot
- patch --forward -p1 < "$srcdir/lerna.diff"
-
# Run the first part of npm run bootstrap
npm install
# Run the second part of npm run bootstrap
- NODE_OPTIONS='--openssl-legacy-provider' npx lerna run bootstrap --stream --load-env-files=false
+ NODE_OPTIONS='--openssl-legacy-provider' npx lerna run bootstrap --stream
}
pkgver() {
diff --git a/lerna.diff b/lerna.diff
deleted file mode 100644
index b84a6c2869b6..000000000000
--- a/lerna.diff
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/lerna.json b/lerna.json
-index 2e5924d12..05a4d9fe6 100644
---- a/lerna.json
-+++ b/lerna.json
-@@ -1,4 +1,5 @@
- {
- "packages": ["packages/*", "configs/*", "scripts"],
-- "version": "independent"
-+ "version": "independent",
-+ "useNx": false
- }