summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhanghua0002021-10-13 15:28:15 +0800
committerzhanghua0002021-10-13 15:28:15 +0800
commit209838cb2e51e63c2ff729a6b1c2b9f3938ecfa2 (patch)
treec20827cd2881b8e66620e695f4a6462937d4fe21
downloadaur-209838cb2e51e63c2ff729a6b1c2b9f3938ecfa2.tar.gz
First release
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bc9ad8940a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mongodb-tools-git
+ pkgdesc = The MongoDB tools provide import, export, and diagnostic capabilities.
+ pkgver = 100.5.1.d62df26a
+ pkgrel = 1
+ url = https://github.com/mongodb/mongo-tools
+ arch = x86_64
+ arch = aarch64
+ license = Apache
+ makedepends = go
+ makedepends = git
+ depends = libpcap
+ provides = mongodb-tools
+ conflicts = mongodb-tools
+ source = git+https://github.com/mongodb/mongo-tools
+ sha512sums = SKIP
+
+pkgname = mongodb-tools-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..55c5af47158b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.pkg.tar.*
+mongo-tools
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6bc1160c4b0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Zhang Hua <zhanghua.00@qq.com>
+# Contributer: James P. Harvey <jamespharvey20 at gmail dot com>
+# Contributer: Christoph Bayer <chrbayer@criby.de>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Fredy GarcĂ­a <frealgagu at gmail dot com>
+
+pkgname=mongodb-tools-git
+pkgver=100.5.1.d62df26a
+pkgrel=1
+pkgdesc="The MongoDB tools provide import, export, and diagnostic capabilities."
+arch=('x86_64' 'aarch64')
+url="https://github.com/mongodb/mongo-tools"
+license=('Apache')
+depends=('libpcap')
+makedepends=('go' 'git')
+conflicts=('mongodb-tools')
+provides=('mongodb-tools')
+source=("git+${url}")
+sha512sums=('SKIP')
+
+pkgver(){
+ cd "${srcdir}/mongo-tools"
+ echo $(git describe --tags).$(git rev-parse --short HEAD)
+}
+build(){
+ cd "${srcdir}/mongo-tools"
+ export GOPATH="${srcdir}/go"
+ ./make build
+}
+package(){
+ cd "${srcdir}/mongo-tools"
+ mkdir -p "${pkgdir}/usr/bin"
+ install -Dm755 bin/* "${pkgdir}/usr/bin"
+}