summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustKidding2023-07-09 20:05:46 -0500
committerJustKidding2023-07-09 20:05:46 -0500
commit6d1fa8fe7e920dbb359a29eeb45bb7238bbfe2ef (patch)
treeae56b3073b4ab593b5a371d3ddb61312a587e2e4
parentc69493abd803e587e23000b14e15ee9a8df7c677 (diff)
downloadaur-6d1fa8fe7e920dbb359a29eeb45bb7238bbfe2ef.tar.gz
upgpkg: mongodb50 5.0.18-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--mongodb-4.4.8-gcc-13.patch23
3 files changed, 35 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e1387716949..9dbaec49dca9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mongodb50
pkgdesc = A high-performance, open source, schema-free document-oriented database
- pkgver = 5.0.15
+ pkgver = 5.0.18
pkgrel = 1
url = https://www.mongodb.com/
arch = x86_64
@@ -21,10 +21,10 @@ pkgbase = mongodb50
depends = curl
optdepends = mongodb-tools: mongoimport, mongodump, mongotop, etc
optdepends = mongosh-bin: interactive shell to connect with MongoDB
- provides = mongodb=5.0.15
+ provides = mongodb=5.0.18
conflicts = mongodb
backup = etc/mongodb.conf
- source = https://fastdl.mongodb.org/src/mongodb-src-r5.0.15.tar.gz
+ source = https://fastdl.mongodb.org/src/mongodb-src-r5.0.18.tar.gz
source = mongodb.sysusers
source = mongodb.tmpfiles
source = mongodb-4.4.1-boost.patch
@@ -36,7 +36,8 @@ pkgbase = mongodb50
source = mongodb-5.0.2-boost-1.79.patch
source = mongodb-5.0.5-no-force-lld.patch
source = mongodb-4.4.10-boost-1.81.patch
- sha256sums = 6f681ac44d494d4bc48de159080ccd53ae2fac337c6bde807f5f78ebd171f852
+ source = mongodb-4.4.8-gcc-13.patch
+ sha256sums = b6f4240c1c1761165b22e493e3d249e53f73cd87bfe0143cba5d6f5069571f12
sha256sums = 3757d548cfb0e697f59b9104f39a344bb3d15f802608085f838cb2495c065795
sha256sums = b7d18726225cd447e353007f896ff7e4cbedb2f641077bce70ab9d292e8f8d39
sha256sums = d3bc20d0cb4b8662b5326b8a3f2215281df5aed57550fa13de465e05e2044c25
@@ -48,5 +49,6 @@ pkgbase = mongodb50
sha256sums = a04aec4f8bd99ad213e31eb45a9e1658695442082e7c4f8c4044f6326eaa1acd
sha256sums = f79f65824f81753d41d2274a6904930db11b06fe08f1442a24c30060cab27e32
sha256sums = 7bfeadf2fb7e13bd93c4515faada070410ddd8e276cc947b5b2b2292539051b7
+ sha256sums = 99ca771ae8d8f2617b1cf002586e10e1501dbde80407f5a555bfed4ab183569e
pkgname = mongodb50
diff --git a/PKGBUILD b/PKGBUILD
index 2ee96721f303..4295277e6dc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mongodb50
_pkgname=mongodb
# #.<odd number>.# releases are unstable development/testing
-pkgver=5.0.15
+pkgver=5.0.18
pkgrel=1
pkgdesc="A high-performance, open source, schema-free document-oriented database"
arch=("x86_64")
@@ -27,8 +27,9 @@ source=(https://fastdl.mongodb.org/src/mongodb-src-r$pkgver.tar.gz
mongodb-5.0.2-skip-reqs-check.patch
mongodb-5.0.2-boost-1.79.patch
mongodb-5.0.5-no-force-lld.patch
- mongodb-4.4.10-boost-1.81.patch)
-sha256sums=('6f681ac44d494d4bc48de159080ccd53ae2fac337c6bde807f5f78ebd171f852'
+ mongodb-4.4.10-boost-1.81.patch
+ mongodb-4.4.8-gcc-13.patch)
+sha256sums=('b6f4240c1c1761165b22e493e3d249e53f73cd87bfe0143cba5d6f5069571f12'
'3757d548cfb0e697f59b9104f39a344bb3d15f802608085f838cb2495c065795'
'b7d18726225cd447e353007f896ff7e4cbedb2f641077bce70ab9d292e8f8d39'
'd3bc20d0cb4b8662b5326b8a3f2215281df5aed57550fa13de465e05e2044c25'
@@ -39,7 +40,8 @@ sha256sums=('6f681ac44d494d4bc48de159080ccd53ae2fac337c6bde807f5f78ebd171f852'
'4ff40320e04bf8c3e05cbc662f8ea549a6b8494d1fda64b1de190c88587bfafd'
'a04aec4f8bd99ad213e31eb45a9e1658695442082e7c4f8c4044f6326eaa1acd'
'f79f65824f81753d41d2274a6904930db11b06fe08f1442a24c30060cab27e32'
- '7bfeadf2fb7e13bd93c4515faada070410ddd8e276cc947b5b2b2292539051b7')
+ '7bfeadf2fb7e13bd93c4515faada070410ddd8e276cc947b5b2b2292539051b7'
+ '99ca771ae8d8f2617b1cf002586e10e1501dbde80407f5a555bfed4ab183569e')
_scons_args=(
CC="${CC:-gcc}"
diff --git a/mongodb-4.4.8-gcc-13.patch b/mongodb-4.4.8-gcc-13.patch
new file mode 100644
index 000000000000..daf406d18dbc
--- /dev/null
+++ b/mongodb-4.4.8-gcc-13.patch
@@ -0,0 +1,23 @@
+https://cgit.openembedded.org/meta-openembedded-contrib/commit/?id=856c21b061e000640829e158b9bb9e978a974386
+
+From 5d8218b8a1b5bc71e2a0cf543a000e194daba599 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 29 Jan 2023 17:15:30 -0800
+Subject: [PATCH] free_mon: Include missing <cstdint>
+
+gcc 13 moved some includes around and as a result <cstdint> is no
+longer transitively included [1]. Explicitly include it
+for uintXX_t.
+
+[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/src/mongo/db/free_mon/free_mon_options.h
++++ b/src/mongo/db/free_mon/free_mon_options.h
+@@ -29,6 +29,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <string>
+ #include <vector>