summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAli Molaei2022-07-29 19:17:29 +0430
committerAli Molaei2022-07-29 19:17:29 +0430
commit0272f12dc7bbe9f96e8c0ca955cba5f6e1b0ace3 (patch)
treeb64ab11d99e11b514a723b641d4873dbb36d945f
parentdb2c1cdae556c1643981f221ec754766afbfe24c (diff)
downloadaur-0272f12dc7bbe9f96e8c0ca955cba5f6e1b0ace3.tar.gz
Fix: stop x86_64 folder always being used
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3e4b112162e..6265191b3ce6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mongosh-bin
pkgdesc = An interactive shell to connect with MongoDB with syntax highlighting, autocomplete, contextual help and error messages.
pkgver = 1.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mongodb-js/mongosh.git
arch = x86_64
arch = aarch64
diff --git a/PKGBUILD b/PKGBUILD
index 482d06eca9e5..fcdd638e6b21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=mongosh-bin
_pkgname=mongosh
pkgver=1.5.1
-pkgrel=1
+pkgrel=2
pkgdesc='An interactive shell to connect with MongoDB with syntax highlighting, autocomplete, contextual help and error messages.'
arch=('x86_64' 'aarch64')
depends=('krb5')
url='https://github.com/mongodb-js/mongosh.git'
license=('Apache')
-_mongosh_file=mongosh-${pkgver}-linux-x64
+_mongosh_folder=mongosh-${pkgver}-linux
source_x86_64=("https://downloads.mongodb.com/compass/${_pkgname}-${pkgver}-linux-x64.tgz")
sha256sums_x86_64=('ef52d411fef065e2bebc0599caa4984c0c39e48dc63ab6ae887ad0d876b41e2c')
@@ -18,7 +18,12 @@ source_aarch64=("https://downloads.mongodb.com/compass/${_pkgname}-${pkgver}-lin
sha256sums_aarch64=('a31bb7c6d35cc4e1656575e67a749af3d8f14dc0704fbe38b46a89c1f58d96e3')
package() {
- install -D $_mongosh_file/bin/mongosh "$pkgdir/usr/bin/mongosh"
- install -D $_mongosh_file/bin/mongosh_crypt_v1.so "$pkgdir/usr/lib/mongosh_crypt_v1.so"
- install -Dm644 $_mongosh_file/mongosh.1.gz "$pkgdir/usr/share/man/man1/mongosh.1.gz"
+ if [ $CARCH = 'x86_64' ]; then
+ _arch=x64;
+ elif [ $CARCH = 'aarch64' ]; then
+ _arch=arm64;
+ fi
+ install -D $_mongosh_folder-${_arch}/bin/mongosh "$pkgdir/usr/bin/mongosh"
+ install -D $_mongosh_folder-${_arch}/bin/mongosh_crypt_v1.so "$pkgdir/usr/lib/mongosh_crypt_v1.so"
+ install -Dm644 $_mongosh_folder-${_arch}/mongosh.1.gz "$pkgdir/usr/share/man/man1/mongosh.1.gz"
}