summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Quisbert2021-08-21 13:25:13 +0200
committerAlejandro Quisbert2021-08-21 13:35:35 +0200
commit66a1729ceb99bb0a7d2a5f24ea6981484ec0e83c (patch)
treeaab6d3a3ccb52cdeb89b34768ffcf4a8fedf65b8
parent501af02d40f3183f3832263a2faaae94c43fba4a (diff)
downloadaur-66a1729ceb99bb0a7d2a5f24ea6981484ec0e83c.tar.gz
Fix dependencies accoding to namcap suggestions
`namcap` shows up two dependencies instead of `glibc`. Therefore it `xz` and `kb5` are included. Removing unnecesary and unused steps when building.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 665641d295b3..2cabbf738662 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = mongosh-bin
pkgdesc = An interactive shell to connect with MongoDB with syntax highlighting, autocomplete, contextual help and error messages.
pkgver = 1.0.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mongodb-js/mongosh.git
arch = x86_64
license = Apache
makedepends = tar
- depends = glibc
+ depends = xz
+ depends = krb5
source = https://downloads.mongodb.com/compass/mongosh-1.0.5-linux-x64.tgz
sha256sums = 0e47c60e99dbfb2cc55696a384bd8d23e03df0026ea629e27ceef40e7f0d1770
diff --git a/PKGBUILD b/PKGBUILD
index 3c0390caa215..9e4f8c5c2437 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Maintainer: Alejandro Quisbert <alejandropqc@protonmail.com>
+# Maintainer: Alejandro Quisbert <alejandropqc at protonmail dot com>
pkgname=mongosh-bin
_pkgname=mongosh
pkgver=1.0.5
-pkgrel=1
+pkgrel=2
pkgdesc='An interactive shell to connect with MongoDB with syntax highlighting, autocomplete, contextual help and error messages.'
arch=('x86_64')
-depends=('glibc')
+depends=('xz' 'krb5')
makedepends=('tar')
url='https://github.com/mongodb-js/mongosh.git'
license=('Apache')
@@ -18,8 +18,6 @@ sha256sums=('0e47c60e99dbfb2cc55696a384bd8d23e03df0026ea629e27ceef40e7f0d1770')
package() {
- cd "${srcdir}"
- tar -zxvf $_mongosh_file.tgz
install -D $_mongosh_file/bin/mongocryptd-mongosh "$pkgdir/usr/bin/mongocryptd-mongosh"
install -D $_mongosh_file/bin/mongosh "$pkgdir/usr/bin/mongosh"