summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Quisbert2021-07-17 19:59:27 +0200
committerAlejandro Quisbert2021-07-17 19:59:27 +0200
commit78ee294aee6f1ed487897c2920ec0f5753b31714 (patch)
tree7bb2a012dee76611fae5af436955fd8f1ebe1f89
downloadaur-78ee294aee6f1ed487897c2920ec0f5753b31714.tar.gz
Base PKGBUILD created
Mongosh basic installation from tarball source with x86_64 architecture.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1844bb60f031
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = mongosh-bin
+ pkgdesc = An interactive shell to connect with MongoDB with syntax highlighting, autocomplete, contextual help and error messages.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/mongodb-js/mongosh.git
+ arch = x86_64
+ license = Apache
+ makedepends = tar
+ depends = glibc
+ source = https://downloads.mongodb.com/compass/mongosh-1.0.0-linux-x64.tgz
+ sha256sums = 7d6ef14e8abdb22904fbb3aafa1bbcc8d3b71be48b6ba881d0cf36124c99f396
+
+pkgname = mongosh-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc5543a0b6a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alejandro Quisbert <alejandropqc@protonmail.com>
+
+pkgname=mongosh-bin
+_pkgname=mongosh
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='An interactive shell to connect with MongoDB with syntax highlighting, autocomplete, contextual help and error messages.'
+arch=('x86_64')
+depends=('glibc')
+makedepends=('tar')
+url='https://github.com/mongodb-js/mongosh.git'
+license=('Apache')
+_mongosh_file=mongosh-${pkgver}-linux-x64
+
+source=("https://downloads.mongodb.com/compass/${_pkgname}-${pkgver}-linux-x64.tgz")
+sha256sums=('7d6ef14e8abdb22904fbb3aafa1bbcc8d3b71be48b6ba881d0cf36124c99f396')
+
+
+package() {
+
+ cd "${srcdir}"
+ tar -zxvf $_mongosh_file.tgz
+ install -D $_mongosh_file/bin/mongocryptd-mongosh "$pkgdir/usr/bin/mongocryptd-mongosh"
+ install -D $_mongosh_file/bin/mongosh "$pkgdir/usr/bin/mongosh"
+
+} \ No newline at end of file