summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAli Molaei2022-08-14 21:59:07 +0430
committerAli Molaei2022-08-14 21:59:07 +0430
commitaa8c67d92207b0b3d2c82b8dd64db539784ebfd6 (patch)
tree5fc15bec011a81a5b9e27d51dc1095990f5ee1a7
parent0272f12dc7bbe9f96e8c0ca955cba5f6e1b0ace3 (diff)
downloadaur-aa8c67d92207b0b3d2c82b8dd64db539784ebfd6.tar.gz
Update to 1.5.4
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD8
3 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6265191b3ce6..babd6dfe87e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = mongosh-bin
pkgdesc = An interactive shell to connect with MongoDB with syntax highlighting, autocomplete, contextual help and error messages.
- pkgver = 1.5.1
- pkgrel = 2
+ pkgver = 1.5.4
+ pkgrel = 1
url = https://github.com/mongodb-js/mongosh.git
arch = x86_64
arch = aarch64
license = Apache
depends = krb5
- source_x86_64 = https://downloads.mongodb.com/compass/mongosh-1.5.1-linux-x64.tgz
- sha256sums_x86_64 = ef52d411fef065e2bebc0599caa4984c0c39e48dc63ab6ae887ad0d876b41e2c
- source_aarch64 = https://downloads.mongodb.com/compass/mongosh-1.5.1-linux-arm64.tgz
- sha256sums_aarch64 = a31bb7c6d35cc4e1656575e67a749af3d8f14dc0704fbe38b46a89c1f58d96e3
+ source_x86_64 = https://downloads.mongodb.com/compass/mongosh-1.5.4-linux-x64.tgz
+ sha256sums_x86_64 = 11ed5b126848dc29de0ea354f479a6f317eec70889fd56f9f4d2b2790f8ca34c
+ source_aarch64 = https://downloads.mongodb.com/compass/mongosh-1.5.4-linux-arm64.tgz
+ sha256sums_aarch64 = a5394a767e9b67e188fb45247f348f6a3348bc6a476fa84a340102fe15dcd9f1
pkgname = mongosh-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4e914d7aac00
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+mongosh-*
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
index fcdd638e6b21..8a6a463e1286 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=mongosh-bin
_pkgname=mongosh
-pkgver=1.5.1
-pkgrel=2
+pkgver=1.5.4
+pkgrel=1
pkgdesc='An interactive shell to connect with MongoDB with syntax highlighting, autocomplete, contextual help and error messages.'
arch=('x86_64' 'aarch64')
depends=('krb5')
@@ -13,9 +13,9 @@ license=('Apache')
_mongosh_folder=mongosh-${pkgver}-linux
source_x86_64=("https://downloads.mongodb.com/compass/${_pkgname}-${pkgver}-linux-x64.tgz")
-sha256sums_x86_64=('ef52d411fef065e2bebc0599caa4984c0c39e48dc63ab6ae887ad0d876b41e2c')
+sha256sums_x86_64=('11ed5b126848dc29de0ea354f479a6f317eec70889fd56f9f4d2b2790f8ca34c')
source_aarch64=("https://downloads.mongodb.com/compass/${_pkgname}-${pkgver}-linux-arm64.tgz")
-sha256sums_aarch64=('a31bb7c6d35cc4e1656575e67a749af3d8f14dc0704fbe38b46a89c1f58d96e3')
+sha256sums_aarch64=('a5394a767e9b67e188fb45247f348f6a3348bc6a476fa84a340102fe15dcd9f1')
package() {
if [ $CARCH = 'x86_64' ]; then