diff options
author | Alejandro Quisbert | 2021-08-21 14:08:30 +0200 |
---|---|---|
committer | Alejandro Quisbert | 2021-08-21 14:08:30 +0200 |
commit | d54cc4ef7cd8a4afa0117e7153aab72c9f3f0ea2 (patch) | |
tree | 5713af8c9ababa3915ec8859928b68c5551fd469 | |
parent | 66a1729ceb99bb0a7d2a5f24ea6981484ec0e83c (diff) | |
download | aur-d54cc4ef7cd8a4afa0117e7153aab72c9f3f0ea2.tar.gz |
Adding arm64 support
Including URL and checksum for ARM64 support. `tar` removed due to
redundancy with makepkg process
-rw-r--r-- | .SRCINFO | 8 | ||||
-rw-r--r-- | PKGBUILD | 10 |
2 files changed, 10 insertions, 8 deletions
@@ -4,11 +4,13 @@ pkgbase = mongosh-bin pkgrel = 2 url = https://github.com/mongodb-js/mongosh.git arch = x86_64 + arch = aarch64 license = Apache - makedepends = tar depends = xz depends = krb5 - source = https://downloads.mongodb.com/compass/mongosh-1.0.5-linux-x64.tgz - sha256sums = 0e47c60e99dbfb2cc55696a384bd8d23e03df0026ea629e27ceef40e7f0d1770 + source_x86_64 = https://downloads.mongodb.com/compass/mongosh-1.0.5-linux-x64.tgz + sha256sums_x86_64 = 0e47c60e99dbfb2cc55696a384bd8d23e03df0026ea629e27ceef40e7f0d1770 + source_aarch64 = https://downloads.mongodb.com/compass/mongosh-1.0.5-linux-arm64.tgz + sha256sums_aarch64 = 21aa0655de4af6eeb01e4d8019f7cebbb7fa24743a3092d2f4628a92d5a0811b pkgname = mongosh-bin @@ -5,16 +5,16 @@ _pkgname=mongosh pkgver=1.0.5 pkgrel=2 pkgdesc='An interactive shell to connect with MongoDB with syntax highlighting, autocomplete, contextual help and error messages.' -arch=('x86_64') +arch=('x86_64' 'aarch64') depends=('xz' 'krb5') -makedepends=('tar') url='https://github.com/mongodb-js/mongosh.git' license=('Apache') _mongosh_file=mongosh-${pkgver}-linux-x64 -source=("https://downloads.mongodb.com/compass/${_pkgname}-${pkgver}-linux-x64.tgz") -sha256sums=('0e47c60e99dbfb2cc55696a384bd8d23e03df0026ea629e27ceef40e7f0d1770') - +source_x86_64=("https://downloads.mongodb.com/compass/${_pkgname}-${pkgver}-linux-x64.tgz") +sha256sums_x86_64=('0e47c60e99dbfb2cc55696a384bd8d23e03df0026ea629e27ceef40e7f0d1770') +source_aarch64=("https://downloads.mongodb.com/compass/${_pkgname}-${pkgver}-linux-arm64.tgz") +sha256sums_aarch64=('21aa0655de4af6eeb01e4d8019f7cebbb7fa24743a3092d2f4628a92d5a0811b') package() { |