summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin2016-04-22 13:47:34 -0400
committerJustin2016-04-22 13:47:34 -0400
commit7770b41f46e3d277a6f60482d9194324c887233c (patch)
tree5a9ad0ba2d493aa3c5f5aa51a0715141a1db5c98
downloadaur-7770b41f46e3d277a6f60482d9194324c887233c.tar.gz
Original AUR package for Mongotron maintained by Ethan Apodaca <papadaca@gmail.com
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD37
-rw-r--r--mongotron-bin.desktop8
-rw-r--r--mongotron-bin.install11
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de7c59b28f0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by mksrcinfo v8
+# Thu Jan 21 05:45:41 UTC 2016
+pkgbase = mongotron-bin
+ pkgdesc = Chrome-based mongo db management tool - Precompiled binary from official repository
+ pkgver = 1.0.0.alpha2
+ pkgrel = 1
+ url = https://github.com/officert/mongotron
+ install = mongotron-bin.install
+ arch = x86_64
+ license = MIT
+ makedepends = imagemagick
+ depends = gconf
+ depends = gtk2
+ depends = libnotify
+ depends = libxtst
+ depends = nss
+ depends = python2
+ depends = xdg-utils
+ depends = desktop-file-utils
+ depends = alsa-lib
+ depends = libgnome-keyring
+ options = !strip
+ source = mongotron-bin.desktop
+ source = mongotron-bin.install
+ source = https://github.com/officert/mongotron/releases/download/v1.0.0-alpha.2/Mongotron-linux-x64.zip
+ sha256sums = bb19bb92859ffd1c35f98cff6380dac43529800654cb9097742a0075ca2e4eeb
+ sha256sums = 9fe12f1bc573f5d431fcc8f9ca3ed17fc1e1d30248ae3b58209fc53084ae0a4e
+ sha256sums = 0f89e95299de6cf447a0276ced3960424dfa94fa270174cc892a2dfe0a46c2ad
+
+pkgname = mongotron-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4eff71a516f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer Ethan Apodaca <papodaca at gmail dot com>
+# Upstream URL: https://github.com/officert/mongotron
+
+pkgname=mongotron-bin
+pkgver=1.0.0.alpha2
+pkgrel=1
+pkgdesc="Chrome-based mongo db management tool - Precompiled binary from official repository"
+arch=("x86_64")
+url="https://github.com/officert/mongotron"
+license=("MIT")
+options=(!strip)
+depends=("gconf" "gtk2" "libnotify" "libxtst" "nss" "python2" "xdg-utils" "desktop-file-utils" "alsa-lib" "libgnome-keyring")
+makedepends=("imagemagick")
+install=$pkgname.install
+
+sha256sums=("bb19bb92859ffd1c35f98cff6380dac43529800654cb9097742a0075ca2e4eeb"
+ "9fe12f1bc573f5d431fcc8f9ca3ed17fc1e1d30248ae3b58209fc53084ae0a4e"
+ "0f89e95299de6cf447a0276ced3960424dfa94fa270174cc892a2dfe0a46c2ad")
+source=("${pkgname}.desktop"
+ "${pkgname}.install"
+ "https://github.com/officert/mongotron/releases/download/v1.0.0-alpha.2/Mongotron-linux-x64.zip")
+
+package() {
+ mkdir "${pkgdir}/opt"
+ mv "${srcdir}/Mongotron-linux-x64" "${pkgdir}/opt/${pkgname}"
+ install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/mongotron.desktop
+ cd "${pkgdir}/opt/$pkgname/resources/app/resources/icon/"
+ convert logo_icon.ico logo_icon.png
+ cd -
+ sizes=(256x256 128x128 48x48 32x32 16x16)
+ for i in 0 1 2 3 4 5 ; do
+ install -d "${pkgdir}/usr/share/icons/hicolor/${sizes[$i]}/apps"
+ ln -s "/opt/${pkgname}/resources/app/resources/icon/logo_icon-${i}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${sizes[$i]}/apps/${pkgname}.png"
+ done
+}
+
diff --git a/mongotron-bin.desktop b/mongotron-bin.desktop
new file mode 100644
index 000000000000..5bf3e131339a
--- /dev/null
+++ b/mongotron-bin.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Mongotron
+Comment=Mongodb admin utility
+Exec=/opt/mongotron-bin/Mongotron
+Icon=mongotron-bin
+Categories=Database;
+Terminal=false
diff --git a/mongotron-bin.install b/mongotron-bin.install
new file mode 100644
index 000000000000..e111ef946053
--- /dev/null
+++ b/mongotron-bin.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}