summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-05-01 19:25:30 +0000
committerAntonio Rojas2020-05-01 19:25:30 +0000
commitb6a420993b953c985654e578a6077f255490651d (patch)
treeb645e8188c0cb684e917a6453fb9490abac429fb
downloadaur-b6a420993b953c985654e578a6077f255490651d.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
-rw-r--r--monica.pngbin0 -> 525 bytes
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc1198a39a38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = monica
+ pkgdesc = Monitor calibration tool
+ pkgver = 3.7
+ pkgrel = 6
+ url = https://sources.archlinux.org/other/monica/
+ arch = x86_64
+ license = BSD
+ makedepends = gendesk
+ depends = fltk
+ depends = xorg-xgamma
+ source = https://sources.archlinux.org/other/monica/monica-3.7.tar.bz2
+ source = monica.png
+ sha512sums = 87565f33f3c3492b196905e5b8e17bd45a7eb8eb0a0281f02e23337eec888af82571ac6f2d229256ee97012d402b7f1b217cd56a8b87ff9c9296931bf63cb153
+ sha512sums = 1a839c9481528dcb785011417a0b77d925b3ae373c6d5fd4a48bab89091c2508079988db38e9dd21e8ed6922c8178b5f3c05beec455deba94ad304b85b990670
+
+pkgname = monica
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15ce8e9734a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Alexander F Rødseth <rodseth@gmail.com>
+# Contributor: tobias <tobias@archlinux.org>
+# Contributor: Tobias Kieslich <tobias@justdreams.de>
+
+pkgname=monica
+pkgver=3.7
+pkgrel=6
+pkgdesc='Monitor calibration tool'
+arch=('x86_64')
+url='https://sources.archlinux.org/other/monica/'
+license=('BSD')
+depends=('fltk' 'xorg-xgamma')
+makedepends=('gendesk')
+source=("https://sources.archlinux.org/other/monica/$pkgname-$pkgver.tar.bz2"
+ 'monica.png')
+sha512sums=('87565f33f3c3492b196905e5b8e17bd45a7eb8eb0a0281f02e23337eec888af82571ac6f2d229256ee97012d402b7f1b217cd56a8b87ff9c9296931bf63cb153'
+ '1a839c9481528dcb785011417a0b77d925b3ae373c6d5fd4a48bab89091c2508079988db38e9dd21e8ed6922c8178b5f3c05beec455deba94ad304b85b990670')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" \
+ --categories 'Application;Settings;System'
+}
+
+build() {
+ make -C "$pkgname-$pkgver"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/$pkgname.png" \
+ "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 licence "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/monica.png b/monica.png
new file mode 100644
index 000000000000..8a2b10f863e7
--- /dev/null
+++ b/monica.png
Binary files differ