summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2016-09-06 17:08:14 -1000
committerGaetan Bisson2016-09-06 17:08:14 -1000
commitb78d5914426f794b17b6018d2b58c391255b1a40 (patch)
tree042e7a6e2d882475cab36428009a60758ca75404
downloadaur-b78d5914426f794b17b6018d2b58c391255b1a40.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb5a651a6751
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = monkey
+ pkgdesc = Lightweight and powerful web server
+ pkgver = 1.6.9
+ pkgrel = 1
+ url = http://monkey-project.com/
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = cmake
+ depends = mbedtls
+ options = !emptydirs
+ source = http://monkey-project.com/releases/1.6/monkey-1.6.9.tar.gz
+ sha1sums = 70895f0d82418ad15fd84b15ad845537e26a39ac
+
+pkgname = monkey
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01f05162b1de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=monkey
+pkgver=1.6.9
+pkgrel=1
+pkgdesc='Lightweight and powerful web server'
+url='http://monkey-project.com/'
+arch=('i686' 'x86_64')
+license=('Apache')
+depends=('mbedtls')
+makedepends=('cmake')
+source=("http://monkey-project.com/releases/${pkgver%.*}/monkey-${pkgver}.tar.gz")
+sha1sums=('70895f0d82418ad15fd84b15ad845537e26a39ac')
+
+options=('!emptydirs')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure \
+ --malloc-libc \
+ --mbedtls-shared \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libdir=/usr/lib \
+ --includedir=/usr/include \
+ --sysconfdir=/etc/monkey \
+ --webroot=/srv/http \
+ --default-port=80 \
+ --default-user=http \
+
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -fr "${pkgdir}"/srv/http
+}