summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2019-02-09 09:33:02 +0100
committerCarsten Teibes2019-02-09 09:33:02 +0100
commit179519f5afe13867c87cc1b2cd0dbe130effa805 (patch)
treeac98031a7435db0b7be585554ee84500df4d7170
parentcce46e8f6e7759d9fd0a1d062d74c09f64f5e1ab (diff)
downloadaur-179519f5afe13867c87cc1b2cd0dbe130effa805.tar.gz
[fix] download URL
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD39
2 files changed, 24 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4aeeb8f6dd08..676d019479dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = monkey-bubble
pkgdesc = A Puzzle Bobble clone for one or two players
pkgver = 0.4.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.happypenguin.org/show?Monkey%20Bubble
arch = i686
arch = x86_64
@@ -12,12 +12,12 @@ pkgbase = monkey-bubble
depends = gstreamer0.10
depends = libgnomeui
depends = librsvg
- source = http://home.gna.org/monkeybubble/downloads/monkey-bubble-0.4.0.tar.gz
+ source = http://archive.ubuntu.com/ubuntu/pool/universe/m/monkey-bubble/monkey-bubble_0.4.0.orig.tar.gz
source = desktop-fixes.patch
source = fix-xml.patch
- md5sums = 0de8a05c8c15e08326d244534dc30f22
- md5sums = 7c747f07e295e2c20313e920180710f0
- md5sums = ead203bdc023d3ff69e4355064a2cbea
+ sha256sums = eb96293a0fadbbfc3cd3ae0bbb557d9bf8a4dd8edccdd8ce1b913e8ba49a1c89
+ sha256sums = 039a57e7b70f457e80cb8084e8b1c972c491b02d47ab68ab5477ee01ef8ca482
+ sha256sums = 5c133152fda6446d7fd1d8b6b530056226c72b81c4aa72fe69e43939b622dd20
pkgname = monkey-bubble
diff --git a/PKGBUILD b/PKGBUILD
index 6e2111c847f7..3d4268dcf161 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,44 @@
-# Maintainer: Anton Bazhenov <anton.bazhenov at gmail>
+
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
# Contributor: John McKnight <jmcknight@gmail.com>
pkgname=monkey-bubble
pkgver=0.4.0
-pkgrel=2
+pkgrel=3
pkgdesc="A Puzzle Bobble clone for one or two players"
arch=('i686' 'x86_64')
url="http://www.happypenguin.org/show?Monkey%20Bubble"
license=('GPL')
depends=('esound' 'gstreamer0.10' 'libgnomeui' 'librsvg')
makedepends=('gnome-doc-utils' 'perl-xml-parser')
-source=("http://home.gna.org/monkeybubble/downloads/${pkgname}-${pkgver}.tar.gz"
+source=("http://archive.ubuntu.com/ubuntu/pool/universe/m/$pkgname/${pkgname}_$pkgver.orig.tar.gz"
"desktop-fixes.patch"
"fix-xml.patch")
-md5sums=('0de8a05c8c15e08326d244534dc30f22'
- '7c747f07e295e2c20313e920180710f0'
- 'ead203bdc023d3ff69e4355064a2cbea')
+sha256sums=('eb96293a0fadbbfc3cd3ae0bbb557d9bf8a4dd8edccdd8ce1b913e8ba49a1c89'
+ '039a57e7b70f457e80cb8084e8b1c972c491b02d47ab68ab5477ee01ef8ca482'
+ '5c133152fda6446d7fd1d8b6b530056226c72b81c4aa72fe69e43939b622dd20')
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ cd $pkgname-$pkgver
# Apply Ubuntu patches
patch -Np1 -i ../desktop-fixes.patch
patch -Np1 -i ../fix-xml.patch
# Fix compilation error
- sed -i "s_glib/gthread.h_glib.h_" \
- src/net/message-handler.c \
- src/net/simple-server.c \
- src/ui/main.c
-
- # Compile
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --disable-schemas-install \
- --disable-scrollkeeper
+ sed "s|glib/gthread.h|glib.h|" \
+ -i src/net/message-handler.c src/net/simple-server.c src/ui/main.c
+}
+
+build() {
+ cd $pkgname-$pkgver
+
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --disable-schemas-install --disable-scrollkeeper
make LDFLAGS="-lm" \
CFLAGS="-Wno-error=deprecated-declarations -Wno-error=unused-but-set-variable"
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ make -C $pkgname-$pkgver DESTDIR="$pkgdir/" install
}