summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyndair2021-02-11 19:18:50 +0000
committerkyndair2021-02-11 19:18:50 +0000
commita55d5cc03fc6c884a547430db5be33be82245ad1 (patch)
tree75652d6c5d6652b6e42d327aab557ff5854c33cc
downloadaur-a55d5cc03fc6c884a547430db5be33be82245ad1.tar.gz
Basic pak utils for MI1&2
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..183651a6aeda
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = monkey-island-pakutils-git
+ pkgdesc = Utilities to unpack and repack Monkey Island SE paks
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/timfel/monkey
+ arch = i686
+ arch = pentium4
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = unknown
+ provides = extractpak
+ provides = packpak
+ source = git+https://github.com/timfel/monkey.git
+ sha256sums = SKIP
+
+pkgname = monkey-island-pakutils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1620ea51ee07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: kyndair <kyndair at gmail dot com>
+pkgname=monkey-island-pakutils-git
+_gitname=monkey
+pkgver=1.0
+pkgrel=1
+pkgdesc="Utilities to unpack and repack Monkey Island SE paks"
+arch=('i686' 'pentium4' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/timfel/monkey"
+license=('unknown')
+provides=('extractpak' 'packpak')
+source=('git+https://github.com/timfel/monkey.git')
+sha256sums=('SKIP')
+
+build() {
+ cd "$_gitname"/
+ gcc extractpak.c -o extractpak
+ gcc packpak.c -o packpak
+}
+
+package() {
+ install -Dm755 "${srcdir}/$_gitname/extractpak" "${pkgdir}/usr/bin/extractpak"
+ install -Dm755 "${srcdir}/$_gitname/packpak" "${pkgdir}/usr/bin/packpak"
+ install -Dm644 "${srcdir}/$_gitname/readme.md" "${pkgdir}/usr/share/doc/${pkgname}/readme.md"
+}