summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm Dragon2019-12-10 14:41:42 -0500
committerStorm Dragon2019-12-10 14:41:42 -0500
commiteaf89d9f1dab14c409e44889271409bedaae3eef (patch)
tree812ac0d1d0774f140db3fd8a1ad07f6788c93e53
parenta63eecbe764cfc3f4afdd5367d35bb0dbe992c1b (diff)
downloadaur-eaf89d9f1dab14c409e44889271409bedaae3eef.tar.gz
Updated dependancies and improved the prepare function.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2371ea6a0282..97da6e450cda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = monkeyspank-git
pkgdesc = A reaction based audio game
- pkgver = r13.1b666c1
+ pkgver = r15.5469af2
pkgrel = 1
url = https://gitlab.com/stormdragon2976/monkeyspank
arch = any
@@ -11,6 +11,7 @@ pkgbase = monkeyspank-git
depends = python-pyperclip
depends = python-requests
depends = python-xdg
+ depends = speech-dispatcher
provides = monkeyspank
conflicts = monkeyspank
source = git+https://gitlab.com/stormdragon2976/monkeyspank.git
diff --git a/PKGBUILD b/PKGBUILD
index 7b5d200979e2..4eb27fb31481 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="A reaction based audio game"
arch=('any')
url="https://gitlab.com/stormdragon2976/${_pkgname}"
license=('GPL3')
-depends=('python' 'python-pygame' 'python-pyperclip' 'python-requests' 'python-xdg')
+depends=('python' 'python-pygame' 'python-pyperclip' 'python-requests' 'python-xdg' 'speech-dispatcher')
makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
@@ -25,7 +25,7 @@ pkgver() {
prepare() {
cd "${_pkgname}"
- git submodule update --init
+ git submodule update --init --remote --merge
}
package() {