summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Ostuni2018-04-12 20:09:59 +0200
committerDario Ostuni2018-04-12 20:09:59 +0200
commit0f785d9957f48f68b147c5a71751f59b35677c1b (patch)
treeeec9f0880826df2503e45d29fba235af4dd97cc0
parentd1e56f5b9bbd4057988a509f80172793272bfec5 (diff)
downloadaur-0f785d9957f48f68b147c5a71751f59b35677c1b.tar.gz
Bump to version 4.7
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df635893d3a9..cf5c531a7eac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
# Generated by mksrcinfo v8
-# Thu Mar 29 11:04:39 UTC 2018
+# Thu Apr 12 18:09:55 UTC 2018
pkgbase = mono-basic
pkgdesc = Mono Visual Basic.NET compiler
- pkgver = 4.6
- pkgrel = 3
+ pkgver = 4.7
+ pkgrel = 1
url = http://www.mono-project.com/
arch = i686
arch = x86_64
+ arch = armv7h
+ arch = aarch64
license = GPL
- makedepends = git
depends = mono
- source = git+https://github.com/mono/mono-basic.git#commit=0ebb1bf
- sha256sums = SKIP
+ source = https://github.com/mono/mono-basic/archive/4.7.tar.gz
+ sha384sums = 4f916f37e2a00655cf5533886f3259431abdcdec37d5a18c3a7d056316867605055e5afd1adf792091fca674cb3d5cfa
pkgname = mono-basic
diff --git a/PKGBUILD b/PKGBUILD
index 4522a62d887f..203d0b491f0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,15 @@
# Contributor: Daniel Isenmann <daniel@archlinux.org>
pkgname=mono-basic
-pkgver=4.6
-pkgrel=3
+pkgver=4.7
+pkgrel=1
pkgdesc="Mono Visual Basic.NET compiler"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
license=('GPL')
url="http://www.mono-project.com/"
depends=('mono')
-makedepends=('git')
-source=("git+https://github.com/mono/mono-basic.git#commit=0ebb1bf")
-sha256sums=('SKIP')
+source=("https://github.com/mono/mono-basic/archive/${pkgver}.tar.gz")
+sha384sums=('4f916f37e2a00655cf5533886f3259431abdcdec37d5a18c3a7d056316867605055e5afd1adf792091fca674cb3d5cfa')
build() {
# get rid of that .wapi errors; thanks to brice
@@ -19,13 +18,13 @@ build() {
mkdir -p "${MONO_SHARED_DIR}"
# build mono
- cd ${pkgname}
+ cd ${pkgname}-${pkgver}
./configure --prefix=/usr
make
}
package() {
- cd ${pkgname}
+ cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
}