summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2016-08-08 01:05:16 -0500
committerDan Beste2016-08-08 01:05:16 -0500
commit2d54a7fc033b23cc692b3feee22d631a3706716f (patch)
tree33d326e0e9afc320fbdb3da6ff3b494f44a0e849
parent83309a23a7dfa893048221916b6d1ddbb5a92461 (diff)
downloadaur-2d54a7fc033b23cc692b3feee22d631a3706716f.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD71
2 files changed, 46 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba10af4e0a2f..1c418e264267 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mono-git
pkgdesc = Free implementation of the .NET platform including runtime and compiler
- pkgver = 3.2.3.r8387.g5d93b2a
+ pkgver = 3.2.3.r14253.gf34c022
pkgrel = 1
url = http://www.mono-project.com/
arch = i686
@@ -8,21 +8,24 @@ pkgbase = mono-git
license = GPL
license = LGPL2.1
license = MPL
- license = custom:MITX11
+ license = BSD
+ license = custom=MITX11
+ license = custom=MSPL
makedepends = git
depends = zlib
- depends = libgdiplus>=3.8
+ depends = libgdiplus
depends = sh
depends = python
+ depends = ca-certificates
+ depends = mono
provides = monodoc
- provides = mono=3.12.0
+ provides = mono
conflicts = monodoc
conflicts = mono
options = !makeflags
source = git://github.com/mono/mono.git
source = mono.binfmt.d
md5sums = SKIP
- md5sums = b9ef8a65fea497acf176cca16c1e2402
pkgname = mono-git
diff --git a/PKGBUILD b/PKGBUILD
index cfc78c74eaa6..efa521678bb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,61 +4,66 @@
pkgname=mono-git
_pkgname=mono
-pkgver=3.2.3.r8387.g5d93b2a
+pkgver=3.2.3.r14253.gf34c022
pkgrel=1
pkgdesc="Free implementation of the .NET platform including runtime and compiler"
arch=(i686 x86_64)
-license=('GPL' 'LGPL2.1' 'MPL' 'custom:MITX11')
+license=('GPL' 'LGPL2.1' 'MPL' 'BSD' 'custom=MITX11' 'custom=MSPL')
url="http://www.mono-project.com/"
-depends=('zlib' 'libgdiplus>=3.8' 'sh' 'python')
+depends=('zlib' 'libgdiplus' 'sh' 'python' 'ca-certificates' 'mono')
makedepends=('git')
options=('!makeflags')
-provides=('monodoc' 'mono=3.12.0')
+provides=('monodoc' 'mono')
conflicts=('monodoc' 'mono')
source=(git://github.com/mono/mono.git
mono.binfmt.d)
md5sums=('SKIP'
- 'b9ef8a65fea497acf176cca16c1e2402')
+ 'b9ef8a65fea497acf176cca16c1e2402')
pkgver() {
- cd ${srcdir}/${_pkgname}
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/mono.//;s/\.68//g'
+ cd ${srcdir}/${_pkgname}
+ git describe \
+ --long \
+ --tags \
+ | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/mono.//;s/\.68//g'
}
build() {
- cd "${srcdir}"/${_pkgname}
+ cd "${srcdir}"/${_pkgname}
- # build mono
- ./autogen.sh --prefix=/usr \
- --sysconfdir=/etc \
- --bindir=/usr/bin \
- --sbindir=/usr/bin \
- --disable-quiet-build \
- --disable-system-aot \
- --with-mcs-docs=no
- make
+ # build mono
+ ./autogen.sh --prefix=/usr \
+ --sysconfdir=/etc \
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
+ --disable-quiet-build \
+ --disable-system-aot \
+ --with-mcs-docs=no
+ make
- # build jay
- cd "${srcdir}"/${_pkgname}/mcs/jay
- make
+ # build jay
+ cd "${srcdir}"/${_pkgname}/mcs/jay
+ make
}
package() {
- cd "${srcdir}"/${_pkgname}
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}"/${_pkgname}
+ make DESTDIR="${pkgdir}" install
- # install jay
- pushd "${srcdir}"/${_pkgname}/mcs/jay
- make DESTDIR="${pkgdir}" prefix=/usr INSTALL=../../install-sh install
- popd
+ # install jay
+ pushd "${srcdir}"/${_pkgname}/mcs/jay
+ make DESTDIR="${pkgdir}" prefix=/usr INSTALL=../../install-sh install
+ popd
- # install binfmt conf file and pathes
- install -D -m644 "${srcdir}"/mono.binfmt.d "${pkgdir}"/usr/lib/binfmt.d/mono.conf
+ # install binfmt conf file and pathes
+ install -D -m644 "${srcdir}"/mono.binfmt.d "${pkgdir}"/usr/lib/binfmt.d/mono.conf
- #install license
- mkdir -p "${pkgdir}"/usr/share/licenses/${_pkgname}
- install -m644 mcs/MIT.X11 "${pkgdir}"/usr/share/licenses/${_pkgname}/
+ #install license
+ mkdir -p "${pkgdir}"/usr/share/licenses/${_pkgname}
+ # Not _ideal_ but this contains all of the licenses for the package
+ install -m644 LICENSE "${pkgdir}"/usr/share/licenses/${_pkgname}/
- #fix .pc file to be able to request mono on what it depends, fixes #go-oo build
- sed -i -e "s:#Requires:Requires:" "${pkgdir}"/usr/lib/pkgconfig/mono.pc
+ #fix .pc file to be able to request mono on what it depends, fixes #go-oo build
+ # Unsure _exactly_ what this does. Not touching it for now.
+ sed -i -e "s:#Requires:Requires:" "${pkgdir}"/usr/lib/pkgconfig/mono.pc
}