summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-01-28 20:22:49 -0600
committerDan Beste2017-01-28 20:22:49 -0600
commit328e14e8e7a3ef3e30c406c3c6f49c755249b1cd (patch)
tree0f8c2d6a60b02720937b013da8effba9d98d3969
parentd632d8a936efdaa0c49f71402c997cdcb26ac706 (diff)
downloadaur-328e14e8e7a3ef3e30c406c3c6f49c755249b1cd.tar.gz
Cleanup
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD93
3 files changed, 83 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c2570c14e57..f5357f24717e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,28 +5,28 @@ pkgbase = mono-git
url = http://www.mono-project.com/
arch = i686
arch = x86_64
+ license = custom=MITX11
+ license = custom=MSPL
+ license = BSD
license = GPL
license = LGPL2.1
license = MPL
- license = BSD
- license = custom=MITX11
- license = custom=MSPL
makedepends = git
- depends = zlib
- depends = libgdiplus
- depends = sh
- depends = python
depends = ca-certificates
+ depends = libgdiplus
depends = mono
- provides = monodoc
+ depends = python
+ depends = sh
+ depends = zlib
provides = mono
- conflicts = monodoc
+ provides = monodoc
conflicts = mono
+ conflicts = monodoc
options = !makeflags
source = git://github.com/mono/mono.git
source = mono.binfmt.d
- md5sums = SKIP
- md5sums = b9ef8a65fea497acf176cca16c1e2402
+ sha256sums = SKIP
+ sha256sums = 9a657fc153ef4ce23bf5fc369a26bf4a124e9304bde3744d04c583c54ca47425
pkgname = mono-git
diff --git a/.gitignore b/.gitignore
index 3e5b1b51bacf..d7861c42ce37 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,7 @@
-# Packages
-*.xz
+# Blacklist
+*
-# Package source
-pkg/
-src/
-mono/
+# Whitelist
+!mono.binfmt.d
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 88a11011cc89..13501b07c6ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,76 @@
+# Maintainer: Krakn <dan.ray.beste@gmail.com>
+
+# Previous maintainer(s):
# Maintainer: Daniel Isenmann <daniel@archlinux.org>
# Contributor: Brice Carpentier <brice@dlfp.org>
-pkgname=mono-git
-_pkgname=mono
+pkgname='mono-git'
+_pkgname='mono'
pkgver=r109943.129f185e583
pkgrel=1
-pkgdesc="Free implementation of the .NET platform including runtime and compiler"
-arch=('i686' 'x86_64')
-license=('GPL' 'LGPL2.1' 'MPL' 'BSD' 'custom=MITX11' 'custom=MSPL')
-url="http://www.mono-project.com/"
-depends=('zlib' 'libgdiplus' 'sh' 'python' 'ca-certificates' 'mono')
-makedepends=('git')
-options=('!makeflags')
-provides=('monodoc' 'mono')
-conflicts=('monodoc' 'mono')
-source=('git://github.com/mono/mono.git' 'mono.binfmt.d')
-md5sums=('SKIP' 'b9ef8a65fea497acf176cca16c1e2402')
+pkgdesc='Free implementation of the .NET platform including runtime and compiler'
+url='http://www.mono-project.com/'
+arch=(
+ 'i686'
+ 'x86_64'
+)
+license=(
+ 'custom=MITX11'
+ 'custom=MSPL'
+ 'BSD'
+ 'GPL'
+ 'LGPL2.1'
+ 'MPL'
+)
+depends=(
+ 'ca-certificates'
+ 'libgdiplus'
+ 'mono'
+ 'python'
+ 'sh'
+ 'zlib'
+)
+makedepends=(
+ 'git'
+)
+options=(
+ '!makeflags'
+)
+provides=(
+ 'mono'
+ 'monodoc'
+)
+conflicts=(
+ 'mono'
+ 'monodoc'
+)
+source=(
+ 'git://github.com/mono/mono.git'
+ 'mono.binfmt.d'
+)
+sha256sums=(
+ 'SKIP'
+ '9a657fc153ef4ce23bf5fc369a26bf4a124e9304bde3744d04c583c54ca47425'
+)
pkgver() {
cd "${srcdir}/${_pkgname}" || exit 1
printf "r%s.%s" \
- "$(git rev-list --count HEAD)" \
- "$(git rev-parse --short HEAD)"
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
}
build() {
cd "${srcdir}/${_pkgname}" || exit 1
# Configure mono
- ./autogen.sh --prefix=/usr \
- --sysconfdir=/etc \
- --bindir=/usr/bin \
- --sbindir=/usr/bin \
- --disable-quiet-build \
- --with-mcs-docs=no
+ ./autogen.sh \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
+ --disable-quiet-build \
+ --with-mcs-docs=no
# If mono is unable to bootstrap itself, make sure monolite is available
make get-monolite-latest
@@ -53,17 +90,19 @@ package() {
# Install jay
cd "${srcdir}/${_pkgname}/mcs/jay" || exit 1
make \
- DESTDIR="${pkgdir}" \
- prefix="/usr" \
- INSTALL="../../install-sh" \
- install
+ DESTDIR="${pkgdir}" \
+ prefix="/usr" \
+ INSTALL="../../install-sh" \
+ install
# Install binfmt conf file
- install -m644 -D "${srcdir}/mono.binfmt.d" "${pkgdir}/usr/lib/binfmt.d/mono.conf"
+ install -m644 -D "${srcdir}/mono.binfmt.d" \
+ "${pkgdir}/usr/lib/binfmt.d/mono.conf"
# Install license
mkdir -p "${pkgdir}/usr/share/licenses/${_pkgname}"
- install -m644 -D "${srcdir}/${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/"
+ install -m644 -D "${srcdir}/${_pkgname}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${_pkgname}/"
# Fix .pc file to be able to request mono on what it depends,
# fixes #go-oo build