summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2016-08-11 14:21:41 -0500
committerDan Beste2016-08-11 14:22:43 -0500
commit97131239a77baddc7d881c499a028eb52df0f364 (patch)
tree8dcac8ffc5e38e861304203049dfec6a815d0a8e
parent1ad1546f3a36edf666884c2fdaf2f2b3d5443604 (diff)
downloadaur-97131239a77baddc7d881c499a028eb52df0f364.tar.gz
Clean up PKGBUILD + add .SRCINFO
-rw-r--r--PKGBUILD86
1 files changed, 46 insertions, 40 deletions
diff --git a/PKGBUILD b/PKGBUILD
index efa521678bb9..4efc9a42666f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,12 @@
-# $Id: PKGBUILD 229096 2015-01-15 20:56:23Z daniel $
# Maintainer: Daniel Isenmann <daniel@archlinux.org>
# Contributor: Brice Carpentier <brice@dlfp.org>
pkgname=mono-git
_pkgname=mono
-pkgver=3.2.3.r14253.gf34c022
+pkgver=r108112.c37bbef
pkgrel=1
pkgdesc="Free implementation of the .NET platform including runtime and compiler"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
license=('GPL' 'LGPL2.1' 'MPL' 'BSD' 'custom=MITX11' 'custom=MSPL')
url="http://www.mono-project.com/"
depends=('zlib' 'libgdiplus' 'sh' 'python' 'ca-certificates' 'mono')
@@ -15,55 +14,62 @@ makedepends=('git')
options=('!makeflags')
provides=('monodoc' 'mono')
conflicts=('monodoc' 'mono')
-source=(git://github.com/mono/mono.git
- mono.binfmt.d)
-md5sums=('SKIP'
- 'b9ef8a65fea497acf176cca16c1e2402')
+source=('git://github.com/mono/mono.git' 'mono.binfmt.d')
+md5sums=('SKIP' 'b9ef8a65fea497acf176cca16c1e2402')
pkgver() {
- cd ${srcdir}/${_pkgname}
- git describe \
- --long \
- --tags \
- | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/mono.//;s/\.68//g'
+ cd "${srcdir}"/"${_pkgname}"
+ printf "r%s.%s" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}"/${_pkgname}
+ cd "${srcdir}"/"${_pkgname}"
- # build mono
- ./autogen.sh --prefix=/usr \
- --sysconfdir=/etc \
- --bindir=/usr/bin \
- --sbindir=/usr/bin \
- --disable-quiet-build \
- --disable-system-aot \
- --with-mcs-docs=no
- make
+ # Build mono
+ ./autogen.sh --prefix=/usr \
+ --sysconfdir=/etc \
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
+ --disable-quiet-build \
+ --disable-system-aot \
+ --with-mcs-docs=no
+ make
- # build jay
- cd "${srcdir}"/${_pkgname}/mcs/jay
- make
+ # Build jay
+ cd "${srcdir}"/"${_pkgname}"/mcs/jay
+ make
}
package() {
- cd "${srcdir}"/${_pkgname}
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}"/"${_pkgname}"
+ make DESTDIR="${pkgdir}" install
- # install jay
- pushd "${srcdir}"/${_pkgname}/mcs/jay
- make DESTDIR="${pkgdir}" prefix=/usr INSTALL=../../install-sh install
- popd
+ # Install jay
+ pushd "${srcdir}"/"${_pkgname}"/mcs/jay
+ make DESTDIR="${pkgdir}" \
+ prefix=/usr \
+ INSTALL=../../install-sh \
+ install
+ popd
- # install binfmt conf file and pathes
- install -D -m644 "${srcdir}"/mono.binfmt.d "${pkgdir}"/usr/lib/binfmt.d/mono.conf
+ # Install binfmt conf file and pathes
+ install \
+ -m644 \
+ -D "${srcdir}"/mono.binfmt.d "${pkgdir}"/usr/lib/binfmt.d/mono.conf
- #install license
- mkdir -p "${pkgdir}"/usr/share/licenses/${_pkgname}
- # Not _ideal_ but this contains all of the licenses for the package
- install -m644 LICENSE "${pkgdir}"/usr/share/licenses/${_pkgname}/
+ # Install license
+ mkdir \
+ -p "${pkgdir}"/usr/share/licenses/"${_pkgname}"
- #fix .pc file to be able to request mono on what it depends, fixes #go-oo build
- # Unsure _exactly_ what this does. Not touching it for now.
- sed -i -e "s:#Requires:Requires:" "${pkgdir}"/usr/lib/pkgconfig/mono.pc
+ install \
+ -m644 \
+ -D "LICENSE" "${pkgdir}"/usr/share/licenses/"${_pkgname}"/
+
+ # Fix .pc file to be able to request mono on what it depends,
+ # fixes #go-oo build
+ sed \
+ -i \
+ -e "s:#Requires:Requires:" "${pkgdir}"/usr/lib/pkgconfig/mono.pc
}