summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-06-02 12:57:55 -0500
committerDan Beste2017-06-02 12:57:55 -0500
commit9820757a9a42876ac3c8e25042b46e896d476456 (patch)
treed49b37e9e9b4f71784dc4d27d799f89e05e2ddb9
parentc190be368500ceacfac042f9af26258dfeb55232 (diff)
downloadaur-9820757a9a42876ac3c8e25042b46e896d476456.tar.gz
Finalize refactor
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD68
2 files changed, 85 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5357f24717e..b5a2470e61d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mono-git
pkgdesc = Free implementation of the .NET platform including runtime and compiler
- pkgver = r109943.129f185e583
+ pkgver = 3.2.3.r17752.g077582d3f90
pkgrel = 1
url = http://www.mono-project.com/
arch = i686
@@ -14,18 +14,56 @@ pkgbase = mono-git
makedepends = git
depends = ca-certificates
depends = libgdiplus
- depends = mono
depends = python
- depends = sh
depends = zlib
+ optdepends = mono: Needed if bootstrapping fails
provides = mono
provides = monodoc
conflicts = mono
conflicts = monodoc
- options = !makeflags
- source = git://github.com/mono/mono.git
+ source = git+https://github.com/mono/mono.git
+ source = git+https://github.com/mono/aspnetwebstack.git
+ source = git+https://github.com/mono/Newtonsoft.Json.git
+ source = git+https://github.com/mono/cecil.git
+ source = git+https://github.com/mono/rx.git#branch=rx-oss-v2.2
+ source = ikvm::git+https://github.com/mono/ikvm-fork.git
+ source = git+https://github.com/mono/ikdasm.git
+ source = binary-reference-assemblies::git+https://github.com/mono/reference-assemblies.git
+ source = nunit-lite::git+https://github.com/mono/NUnitLite.git
+ source = nuget-buildtasks::git+https://github.com/mono/NuGet.BuildTasks
+ source = git+https://github.com/mono/buildtools.git
+ source = cecil-legacy::git+https://github.com/mono/cecil.git#branch=mono-legacy-0.9.5
+ source = git+https://github.com/mono/boringssl.git#branch=mono
+ source = git+https://github.com/mono/corefx.git
+ source = git+https://github.com/mono/bockbuild.git
+ source = git+https://github.com/mono/linker.git
+ source = git+https://github.com/mono/roslyn-binaries.git
+ source = git+https://github.com/mono/corert.git
+ source = git+https://github.com/mono/xunit-binaries.git
+ source = git+https://github.com/mono/api-doc-tools.git
+ source = git+https://github.com/mono/api-snapshot.git
source = mono.binfmt.d
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 9a657fc153ef4ce23bf5fc369a26bf4a124e9304bde3744d04c583c54ca47425
pkgname = mono-git
diff --git a/PKGBUILD b/PKGBUILD
index 56f00e891c0b..210a139aeff3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,15 @@
pkgname='mono-git'
_gitname='mono'
-pkgver=3.2.3.r17742.ga560146b7ce
+pkgver=3.2.3.r17752.g077582d3f90
pkgrel=1
pkgdesc='Free implementation of the .NET platform including runtime and compiler'
url='http://www.mono-project.com/'
arch=('i686' 'x86_64')
license=('custom=MITX11' 'custom=MSPL' 'BSD' 'GPL' 'LGPL2.1' 'MPL')
-depends=('ca-certificates' 'libgdiplus' 'python' 'sh' 'zlib')
-makedepends=('git' 'mono')
-#options=('!makeflags')
+depends=('ca-certificates' 'libgdiplus' 'python' 'zlib')
+makedepends=('git')
+optdepends=('mono: Needed if bootstrapping fails')
provides=('mono' 'monodoc')
conflicts=('mono' 'monodoc')
source=(
@@ -56,9 +56,29 @@ pkgver() {
prepare() {
cd "${_gitname}"
- externals=('aspnetwebstack' 'Newtonsoft.Json' 'cecil' 'rx' 'ikvm' 'ikdasm' 'binary-reference-assemblies' 'nunit-lite' 'nuget-buildtasks' 'buildtools' 'cecil-legacy' 'boringssl' 'corefx' 'bockbuild' 'linker' 'roslyn-binaries' 'corert' 'xunit-binaries' 'api-doc-tools' 'api-snapshot')
+ local externals=(
+ 'aspnetwebstack'
+ 'Newtonsoft.Json'
+ 'cecil'
+ 'rx'
+ 'ikvm'
+ 'ikdasm'
+ 'binary-reference-assemblies'
+ 'nunit-lite'
+ 'nuget-buildtasks'
+ 'buildtools'
+ 'cecil-legacy'
+ 'boringssl'
+ 'corefx'
+ 'bockbuild'
+ 'linker'
+ 'roslyn-binaries'
+ 'corert'
+ 'xunit-binaries'
+ 'api-doc-tools' 'api-snapshot'
+ )
- for external in ${externals[@]}; do
+ for external in ""${externals[@]}""; do
submodule="external/${external}"
git submodule init "${submodule}"
git config "submodule.${submodule}.url" "${srcdir}/${external}"
@@ -69,38 +89,34 @@ prepare() {
build() {
cd "${_gitname}"
- ./autogen.sh \
- --prefix=/usr \
- --sysconfdir=/etc \
- --bindir=/usr/bin \
- --sbindir=/usr/bin \
- --disable-quiet-build \
- --with-mcs-docs=no
+ ./autogen.sh --prefix=/usr
+ if ! hash mono; then
+ make get-monolite-latest
+ fi
make
- cd "mcs/jay"
+ cd mcs/jay
- make
+ make
}
package() {
cd "${_gitname}"
make DESTDIR="${pkgdir}" install
+ install -d -m 755 "${pkgdir}/usr/share/licenses/${_gitname}"
+ install -D -m 644 "LICENSE" "${pkgdir}/usr/share/licenses/${_gitname}/"
- cd mcs/jay"
+ cd mcs/jay
- make \
- DESTDIR="${pkgdir}" \
- prefix="/usr" \
- INSTALL="../../install-sh" \
- install
+ make DESTDIR="${pkgdir}" prefix=/usr install
cd "${srcdir}"
- install -D -m 644 mono.binfmt.d "${pkgdir}/usr/lib/binfmt.d/mono.conf"
- install -d -m 755 "${pkgdir}/usr/share/licenses/${_pkgname}"
- install -D -m 644 "${_gitname}/LICENSE" "${pkgdir}/usr/share/licenses/${_gitname}/"
- # Fix .pc file to be able to request mono on what it depends,
- # fixes #go-oo build
+ install -D -m 644 \
+ "${srcdir}/mono.binfmt.d" \
+ "${pkgdir}/usr/lib/binfmt.d/mono.conf"
+
+ # Fix .pc file to be able to request mono on what it depends, fixes #go-oo
+ # build
sed -i -e "s:#Requires:Requires:" "${pkgdir}/usr/lib/pkgconfig/mono.pc"
}