summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormalahx2016-09-18 01:35:06 +0200
committermalahx2016-09-18 01:35:06 +0200
commit9e5b00cdada2df823f6c4a2287da33c7e5926873 (patch)
treeff13e46b64305d3eadbaf3e3369eb66655a975ba
parent60146a9788ca948b3e1e21375c796ffa81420c4e (diff)
downloadaur-mono42.tar.gz
Parallel Mono Environments
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
-rwxr-xr-xmono42-dev-env10
3 files changed, 27 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aecbd701f12a..ba1b783c86ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mono42
pkgdesc = Free implementation of the .NET platform including runtime and compiler
pkgver = 4.2.4.4
- pkgrel = 1
+ pkgrel = 2
url = http://www.mono-project.com/
install = mono42.install
arch = i686
@@ -15,12 +15,10 @@ pkgbase = mono42
depends = sh
depends = python
depends = ca-certificates
- provides = monodoc
- provides = mono=4.2.4.4
- conflicts = monodoc
- conflicts = mono
source = http://download.mono-project.com/sources/mono/mono-4.2.4.4.tar.bz2
+ source = mono42-dev-env
sha256sums = ae74292c672e276276edc5461914f3e184d427a7a2ac099d3ce2640abe5dc0c6
+ sha256sums = 2de4aa94b4f59a840fb5d75f2fb6016dd4f666832fd831316402cffd7187752e
pkgname = mono42
diff --git a/PKGBUILD b/PKGBUILD
index 9ee1fbdc1322..f0b142b7d3f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,27 +7,24 @@ pkgname=mono42
_pkgname=mono
pkgver=4.2.4.4
_pkgver=4.2.4
-pkgrel=1
+pkgrel=2
pkgdesc="Free implementation of the .NET platform including runtime and compiler"
arch=(i686 x86_64)
license=('GPL' 'LGPL2.1' 'MPL' 'custom:MITX11')
url="http://www.mono-project.com/"
depends=('zlib' 'libgdiplus>=3.8' 'sh' 'python' 'ca-certificates')
-provides=('monodoc' "mono=${pkgver}")
-conflicts=('monodoc' 'mono')
install="${pkgname}.install"
-source=(http://download.mono-project.com/sources/mono/${_pkgname}-${pkgver}.tar.bz2)
-sha256sums=('ae74292c672e276276edc5461914f3e184d427a7a2ac099d3ce2640abe5dc0c6')
+source=(http://download.mono-project.com/sources/mono/${_pkgname}-${pkgver}.tar.bz2
+ "mono42-dev-env")
+sha256sums=('ae74292c672e276276edc5461914f3e184d427a7a2ac099d3ce2640abe5dc0c6'
+ '2de4aa94b4f59a840fb5d75f2fb6016dd4f666832fd831316402cffd7187752e')
build() {
cd "${srcdir}"/${_pkgname}-${_pkgver}
# build mono
./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --bindir=/usr/bin \
- --sbindir=/usr/bin \
+ --prefix=/opt/${pkgname} \
--with-mcs-docs=no
make
@@ -42,14 +39,17 @@ package() {
# install jay
pushd "${srcdir}"/${_pkgname}-${_pkgver}/mcs/jay
- make DESTDIR="${pkgdir}" prefix=/usr INSTALL=../../install-sh install
+ make DESTDIR="${pkgdir}" prefix=/opt/${pkgname} INSTALL=../../install-sh install
popd
#install license
- mkdir -p "${pkgdir}"/usr/share/licenses/${_pkgname}
- install -m644 mcs/MIT.X11 "${pkgdir}"/usr/share/licenses/${_pkgname}/
+ mkdir -p "${pkgdir}"/opt/${pkgname}/licenses/${_pkgname}
+ install -m644 mcs/MIT.X11 "${pkgdir}"/opt/${pkgname}/licenses/${_pkgname}/
#fix .pc file to be able to request mono on what it depends, fixes #go-oo build
- sed -i -e "s:#Requires:Requires:" "${pkgdir}"/usr/lib/pkgconfig/mono.pc
- sed -i -e "s:/2.0/:/4.5/:g" "${pkgdir}"/usr/lib/pkgconfig/mono-nunit.pc
+ sed -i -e "s:#Requires:Requires:" "${pkgdir}"/opt/${pkgname}/lib/pkgconfig/mono.pc
+ sed -i -e "s:/2.0/:/4.5/:g" "${pkgdir}"/opt/${pkgname}/lib/pkgconfig/mono-nunit.pc
+
+ #install mono42-dev-env
+ install -m644 "${srcdir}/mono42-dev-env" "${pkgdir}"/opt/${pkgname}/mono42-dev-env
}
diff --git a/mono42-dev-env b/mono42-dev-env
new file mode 100755
index 000000000000..a99e3b3bda0d
--- /dev/null
+++ b/mono42-dev-env
@@ -0,0 +1,10 @@
+#!/bin/bash
+MONO_PREFIX=/opt/mono
+GNOME_PREFIX=/opt/gnome
+export DYLD_FALLBACK_LIBRARY_PATH=$MONO_PREFIX/lib:$DYLD_LIBRARY_FALLBACK_PATH
+export LD_LIBRARY_PATH=$MONO_PREFIX/lib:$LD_LIBRARY_PATH
+export C_INCLUDE_PATH=$MONO_PREFIX/include:$GNOME_PREFIX/include
+export ACLOCAL_PATH=$MONO_PREFIX/share/aclocal
+export PKG_CONFIG_PATH=$MONO_PREFIX/lib/pkgconfig:$GNOME_PREFIX/lib/pkgconfig
+export PATH=$MONO_PREFIX/bin:$PATH
+PS1="[mono42] \w @ " \ No newline at end of file